summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-22 13:50:16 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-22 13:50:16 -0400
commite4de7e7f81d7c20bc078f1661cfaa0f0c136bb6f (patch)
treeb21f44ab01482cf6eaa4ff958496388824ec3092
parent20100720 - Cambio automático (diff)
downloadrubenqba-e4de7e7f81d7c20bc078f1661cfaa0f0c136bb6f.tar.gz
rubenqba-e4de7e7f81d7c20bc078f1661cfaa0f0c136bb6f.tar.bz2
rubenqba-e4de7e7f81d7c20bc078f1661cfaa0f0c136bb6f.zip
adicionando temas de gnome actualizados
-rw-r--r--x11-themes/gnome-themes/Manifest3
-rw-r--r--x11-themes/gnome-themes/files/gnome-themes-2.24.3-bashism.patch13
-rw-r--r--x11-themes/gnome-themes/gnome-themes-2.31.4.ebuild53
-rw-r--r--x11-themes/gtk-engines/Manifest3
-rw-r--r--x11-themes/gtk-engines/files/gtk-engines-2.90.3.1-fix-animation.patch107
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.90.3.1.ebuild39
6 files changed, 218 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes/Manifest b/x11-themes/gnome-themes/Manifest
new file mode 100644
index 0000000..2483850
--- /dev/null
+++ b/x11-themes/gnome-themes/Manifest
@@ -0,0 +1,3 @@
+AUX gnome-themes-2.24.3-bashism.patch 524 RMD160 bdbeb167d71dbaa242dd12a5bae979602d2dbe04 SHA1 cb26e34e085cb6b135a58cf9241308990c40aa4b SHA256 f94fbd406d38ad0878c01f8cbe75573ae21545e42b67b2c51f4248e2cf714b28
+DIST gnome-themes-2.31.4.tar.bz2 2690613 RMD160 98df8c75f73f909bf9bf1abfbaafba8fd1223f38 SHA1 57cd1af2f27949807f77b17fe60e475650f4baed SHA256 851b7304337fb0521b7845b2c0446f2c63cb4d356a638aaff30a2f72842d4e1d
+EBUILD gnome-themes-2.31.4.ebuild 1606 RMD160 1b6ef63f7369d2914bb1bfd881d68be397b6e6ef SHA1 b44bca84e3c96be8bf102d13f65d5f23af518429 SHA256 32c71be9cc590185eb5c00a9f20acd26f98a092d0172a5bffca898e4f05ecffd
diff --git a/x11-themes/gnome-themes/files/gnome-themes-2.24.3-bashism.patch b/x11-themes/gnome-themes/files/gnome-themes-2.24.3-bashism.patch
new file mode 100644
index 0000000..382766f
--- /dev/null
+++ b/x11-themes/gnome-themes/files/gnome-themes-2.24.3-bashism.patch
@@ -0,0 +1,13 @@
+# https://bugs.gentoo.org/show_bug.cgi?id=256337
+# http://bugzilla.gnome.org/show_bug.cgi?id=550927
+--- a/common/mkiconlinks.sh 2008-09-04 17:15:42.000000000 -0500
++++ b/common/mkiconlinks.sh 2008-09-04 17:16:31.000000000 -0500
+@@ -16,7 +16,7 @@
+ while [ ! -z "$NEXTLINE" ] ; do
+
+ # Skip lines beginning with '#'
+- if [ ! "${NEXTLINE:0:1}" == '#' ]; then
++ if ! echo ${NEXTLINE} | grep -q "^#" ; then
+ #Extract first field, minus its trailing colon
+ ORIG_FILE=`echo $NEXTLINE | awk '/:/{print $1}' | sed -e 's/://'`
+
diff --git a/x11-themes/gnome-themes/gnome-themes-2.31.4.ebuild b/x11-themes/gnome-themes/gnome-themes-2.31.4.ebuild
new file mode 100644
index 0000000..879b8bd
--- /dev/null
+++ b/x11-themes/gnome-themes/gnome-themes-2.31.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes/gnome-themes-2.30.1-r1.ebuild,v 1.1 2010/06/13 16:22:59 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="A set of GNOME themes, with sets for users with limited or low vision"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="accessibility"
+
+RDEPEND="x11-libs/gtk+:2
+ >=x11-themes/gtk-engines-2.15.3:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35"
+# dev-perl/XML-LibXML is bug 266136
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+G2CONF="${G2CONF}
+ $(use_enable accessibility all-themes)
+ --disable-test-themes
+ --enable-icon-mapping"
+
+src_prepare() {
+ # Fix bashisms, bug #256337
+ epatch "${FILESDIR}/${PN}-2.24.3-bashism.patch"
+
+ # Do not build/install accessibility themes, bug #274515
+ if ! use accessibility; then
+ sed 's:HighContrast.*\\:\\:g' -i \
+ desktop-themes/Makefile.am desktop-themes/Makefile.in \
+ gtk-themes/Makefile.am gtk-themes/Makefile.in \
+ icon-themes/Makefile.am icon-themes/Makefile.in \
+ || die "sed 1 failed"
+ fi
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed 2 failed"
+}
diff --git a/x11-themes/gtk-engines/Manifest b/x11-themes/gtk-engines/Manifest
new file mode 100644
index 0000000..68c8b00
--- /dev/null
+++ b/x11-themes/gtk-engines/Manifest
@@ -0,0 +1,3 @@
+AUX gtk-engines-2.90.3.1-fix-animation.patch 3930 RMD160 2771b5686e6bcf182640055bba16cef0c667880f SHA1 508fa63f9750add05215bf86dbda94b9d0edefcf SHA256 b849543d69bf54ac9b76973d330a2bedf832c73271f821ab058328562a31215e
+DIST gtk-engines-2.90.3.1.tar.bz2 589473 RMD160 be7d5156d5a39bf83922744f3fe5b60a59843adb SHA1 6a7b3a3325c02a6c0732d548dfbbbf7d789d762e SHA256 8c63eff01121f5b9abd508a1d1996135396ee774c4ef2fbb1a3131c82788eaf0
+EBUILD gtk-engines-2.90.3.1.ebuild 977 RMD160 cdba0b63f7ce9090c532bde255045eefa215c7cf SHA1 3d50968b50cdba7d4f3071bd34a63d395dfdfcf3 SHA256 655cebb42eefa7f0359da327c5b6416084d2771f3715d91cd4ced3d0736d6870
diff --git a/x11-themes/gtk-engines/files/gtk-engines-2.90.3.1-fix-animation.patch b/x11-themes/gtk-engines/files/gtk-engines-2.90.3.1-fix-animation.patch
new file mode 100644
index 0000000..29a78f8
--- /dev/null
+++ b/x11-themes/gtk-engines/files/gtk-engines-2.90.3.1-fix-animation.patch
@@ -0,0 +1,107 @@
+From a484a86cef26420e9278a550d246ff1068a9e88e Mon Sep 17 00:00:00 2001
+From: Benjamin Berg <benjamin@sipsolutions.net>
+Date: Fri, 02 Jul 2010 16:56:24 +0000
+Subject: Fix animation. (bug #622982, #612486)
+
+---
+diff --git a/engines/clearlooks/src/animation.c b/engines/clearlooks/src/animation.c
+index 1f7a41f..d37b85d 100644
+--- a/engines/clearlooks/src/animation.c
++++ b/engines/clearlooks/src/animation.c
+@@ -166,7 +166,7 @@ update_animation_info (gpointer key, gpointer value, gpointer user_data)
+ g_assert ((widget != NULL) && (animation_info != NULL));
+
+ /* remove the widget from the hash table if it is not drawable */
+- if (!GTK_WIDGET_DRAWABLE (widget))
++ if (!gtk_widget_is_drawable (widget))
+ {
+ return TRUE;
+ }
+@@ -267,6 +267,20 @@ find_signal_info (gconstpointer signal_info, gconstpointer widget)
+
+ /* external interface */
+
++#define CL_IS_PROGRESS_BAR(widget) GE_IS_PROGRESS_BAR(widget) && widget->allocation.x != -1 && widget->allocation.y != -1
++gboolean
++clearlooks_animation_is_progressbar (GtkWidget *widget)
++{
++ GtkAllocation allocation;
++ if (!GE_IS_PROGRESS_BAR (widget))
++ return FALSE;
++ gtk_widget_get_allocation (widget, &allocation);
++ if ((allocation.x < 0) || (allocation.y < 0))
++ return FALSE;
++ return TRUE;
++}
++
++
+ /* adds a progress bar */
+ void
+ clearlooks_animation_progressbar_add (GtkWidget *progressbar)
+@@ -331,8 +345,6 @@ clearlooks_animation_cleanup ()
+ stop_timer ();
+ }
+ #else /* !HAVE_WORKING_ANIMATION */
+-/* Warn here so the message is only displayed once. */
+-#warning Disabling animation support as it currently needs deprecated symbols and GTK_DISABLE_DEPRECATED is enabled.
+
+ static void clearlooks_animation_dummy_function_so_wall_shuts_up_when_animations_is_disabled()
+ {
+diff --git a/engines/clearlooks/src/animation.h b/engines/clearlooks/src/animation.h
+index 4ab6f4e..0307783 100644
+--- a/engines/clearlooks/src/animation.h
++++ b/engines/clearlooks/src/animation.h
+@@ -24,22 +24,20 @@
+ #include <config.h>
+
+ #ifdef HAVE_ANIMATION
+-#ifndef GTK_DISABLE_DEPRECATED
+
+ #define HAVE_WORKING_ANIMATION 1
+
+ #include <gtk/gtk.h>
+ #include <ge-support.h>
+
+-#define CL_IS_PROGRESS_BAR(widget) GE_IS_PROGRESS_BAR(widget) && widget->allocation.x != -1 && widget->allocation.y != -1
+ #define ANIMATION_DELAY 100
+ #define CHECK_ANIMATION_TIME 0.5
+
++GE_INTERNAL gboolean clearlooks_animation_is_progressbar (GtkWidget *widget);
+ GE_INTERNAL void clearlooks_animation_progressbar_add (GtkWidget *progressbar);
+ GE_INTERNAL void clearlooks_animation_connect_checkbox (GtkWidget *widget);
+ GE_INTERNAL gboolean clearlooks_animation_is_animated (GtkWidget *widget);
+ GE_INTERNAL gdouble clearlooks_animation_elapsed (gpointer data);
+ GE_INTERNAL void clearlooks_animation_cleanup ();
+-#endif /* GTK_DISABLE_DEPRECATED */
+ #endif /* HAVE_ANIMATION */
+
+diff --git a/engines/clearlooks/src/clearlooks_style.c b/engines/clearlooks/src/clearlooks_style.c
+index 1c02499..07d08bd 100644
+--- a/engines/clearlooks/src/clearlooks_style.c
++++ b/engines/clearlooks/src/clearlooks_style.c
+@@ -604,7 +604,6 @@ clearlooks_style_draw_box (DRAW_ARGS)
+ }
+ else
+ {
+- g_print ("ETCHED IN\n");
+ cairo_save (cr);
+ cairo_move_to (cr, x, y);
+ cairo_line_to (cr, x + width, y);
+@@ -758,12 +757,10 @@ clearlooks_style_draw_box (DRAW_ARGS)
+ gdouble elapsed = 0.0;
+
+ #ifdef HAVE_WORKING_ANIMATION
+- if(clearlooks_style->animation && CL_IS_PROGRESS_BAR (widget))
++ if(clearlooks_style->animation && clearlooks_animation_is_progressbar (widget))
+ {
+- gboolean activity_mode = GTK_PROGRESS_BAR (widget)->activity_mode;
+-
+- if (!activity_mode)
+- clearlooks_animation_progressbar_add ((gpointer)widget);
++#warning Assuming non-pulsing progress bars because there is currently no way to query them in GTK+ 3.0.
++ clearlooks_animation_progressbar_add ((gpointer)widget);
+ }
+
+ elapsed = clearlooks_animation_elapsed (widget);
+--
+cgit v0.8.3.1
diff --git a/x11-themes/gtk-engines/gtk-engines-2.90.3.1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.90.3.1.ebuild
new file mode 100644
index 0000000..8ede060
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.90.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild,v 1.1 2010/06/13 16:16:22 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+3 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility"
+
+RDEPEND=">=x11-libs/gtk+-2.90:3"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable accessibility hc)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-animation.patch
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name "*.la" -delete
+}