aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--net-firewall/nftables/Manifest1
-rw-r--r--net-firewall/nftables/nftables-9999.ebuild40
3 files changed, 43 insertions, 0 deletions
diff --git a/README.md b/README.md
index 21483bd0..51a22702 100644
--- a/README.md
+++ b/README.md
@@ -18,6 +18,8 @@ Various [Gentoo Linux](http://www.gentoo.org/) ebuilds, to provide out-of-tree p
* net-firewall/iptables-nftables
* git live ebuild for nftables' iptables compatibility libraries
+* net-firewall/nftables
+ * git live ebuild for nftables 'nft' binary
# Out-of-tree ebuilds
diff --git a/net-firewall/nftables/Manifest b/net-firewall/nftables/Manifest
new file mode 100644
index 00000000..a101aa92
--- /dev/null
+++ b/net-firewall/nftables/Manifest
@@ -0,0 +1 @@
+EBUILD nftables-9999.ebuild 769 SHA256 2d3752d155c283cbb2c5f2aae10f08b0bc0fdb4f49085a4e4face7a0cc84dddf SHA512 ab27243a996a9215aa898b1f8d7bb2b94807b3a53aad378dc29185d9213f201bb8a971585c70069d3282a1e6e68cfb4bdb81bad731a32a15176dbdf5f5261cab WHIRLPOOL 40f4bb57859600e559781ba0913c106980c80d37d365a2636cee786df616c76cc34a227180beadbeb580ae4e46ec58dc4bddaf5c60527f0c4da89cd1e60a6661
diff --git a/net-firewall/nftables/nftables-9999.ebuild b/net-firewall/nftables/nftables-9999.ebuild
new file mode 100644
index 00000000..308a066e
--- /dev/null
+++ b/net-firewall/nftables/nftables-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools git-2
+
+DESCRIPTION="nftables aims to replace the existing {ip,ip6,arp,eb}tables framework"
+HOMEPAGE="http://www.netfilter.org/projects/nftables/"
+EGIT_REPO_URI="git://git.netfilter.org/${PN}.git"
+EGIT_MASTER="master"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="man pdf"
+
+RDEPEND="
+ dev-libs/gmp
+ net-libs/libmnl
+ net-libs/libnftnl
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ man? ( app-text/docbook2X )
+ pdf? ( app-text/docbook-sgml-utils[tetex] )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-debug
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}