summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwbrana <wbrana@gmail.com>2012-08-31 17:50:37 +0200
committerwbrana <wbrana@gmail.com>2012-08-31 17:50:37 +0200
commit1c3d72b49dc708ec2ba31a16797c5c5578147abf (patch)
treefb3a32c14f087d309777d9ef8d460d9b1f198349
parentversion bump oracle32-jdk-bin to 1.7.0.7 (diff)
downloadwbrana-1c3d72b49dc708ec2ba31a16797c5c5578147abf.tar.gz
wbrana-1c3d72b49dc708ec2ba31a16797c5c5578147abf.tar.bz2
wbrana-1c3d72b49dc708ec2ba31a16797c5c5578147abf.zip
add amd64 only English only www-client/firefox-bin
-rw-r--r--www-client/Manifest5
-rw-r--r--www-client/firefox-bin-15.0.ebuild133
2 files changed, 138 insertions, 0 deletions
diff --git a/www-client/Manifest b/www-client/Manifest
new file mode 100644
index 0000000..3208430
--- /dev/null
+++ b/www-client/Manifest
@@ -0,0 +1,5 @@
+AUX 10firefox-bin 32 SHA256 3163273068698dfc7da0a2edf8e558bb31d30eece410960672674a0eb019dc08 SHA512 24f2c370316540b70b2053e2ac0c8ca67714c928d570c9df9dbeb3b179f29b78e7f6dbdad6e452ef312b796f68f4d7105c92f027e75a56f07084ea9ccb58ab69 WHIRLPOOL ad74d82fb1c9c17cc7b7a5a59dd2a27e0fba26c551cc3127066ddda0b9298a37a14bbaf0a3c4c4fce45aed82e7334a0458851c032fcafdc3fb51eca27d550acc
+AUX firefox-bin-prefs.js 305 SHA256 786fbfc99425ed9ba32d3e99af6b482226539a86e762197cc10e2b491c7b9d72 SHA512 ef65b9a24f22cf04def4962721056869392dddabdac80e6f9cd92c57d58174667475ae55d83fa43603e93dcb1745568d82bcad8c810fb597dd51f2b5099bd69e WHIRLPOOL e19e8e1d4820b8356103ecd358f2e455ca00f6ed59eba6996a032cf97bcd5d3d1af9624e69eb68dbe3e2d4208e1d14e0355407194d9230098b1a118c213ef97d
+AUX firefox-bin.desktop 330 SHA256 5aa85d89a45e4d6706bc046173ff3be10d7af729b04b88f2378cdbda602b648a SHA512 b1838ba89c756e8af226503989d2689a78874af5575bb25a3184c4d09d3393bf3718e22cf4c03ff0ccb17bc04d4c00e84f5fb5500a4a88f4b921613b11d45491 WHIRLPOOL 5b8ed84befaeb6422e1f6154caf5b928e7fa699d6aea6a32160b60d6d030251fd36f46500b824f8746b39e5cec6b6be42bdfeb01f1a370bae7b85c0f28bc957c
+DIST firefox-bin_x86_64-15.0.tar.bz2 21260545 SHA256 29eb6687ab932022b981347a7ca986df8fff119146cb7266c8ba19f8acf3a209 SHA512 e5613ca7c397ac89f69cc5db606fb62ee85829307adf16ea087d31c5922e29b998b0fdcfaa910d7b29014fe62cba4b1a5626af25a68f186c8ab4a1e3079882b2 WHIRLPOOL 4456a3c756c6064c8b0d2d72049ae0149e36ccb61c6028b52cfc8fdc0601391e2a8312493aa1bee733a4c6c54b6967f9e20370181bdfa5858a21b4d7aede1f62
+EBUILD firefox-bin-15.0.ebuild 3566 SHA256 e268ec708a20d3232ad559bc46bb4cf78092c34e09ebb57d42ed7b8879266ded SHA512 4680d0045f03867d64b962a9a7ff3976e2e2ea82bd0f6af3f1ef19a2ecfd6564bd33e10630e8db9e3f9903f2fc4f5e5a9e91da907c756f18a2671d46bb094dc6 WHIRLPOOL 809e756808a026b52b921053fcf9357147abd1467c53860f3ca9116cdea0d5acd660af24edefba1745a394d889558afb5bc04f4972b8353dfdc33e0c1270a574
diff --git a/www-client/firefox-bin-15.0.ebuild b/www-client/firefox-bin-15.0.ebuild
new file mode 100644
index 0000000..fb0db54
--- /dev/null
+++ b/www-client/firefox-bin-15.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-14.0.1.ebuild,v 1.2 2012/07/19 19:07:18 jdhore Exp $
+
+EAPI="4"
+
+# Can be updated using scripts/get_langs.sh from mozilla overlay
+MOZ_LANGS=(en en-US)
+
+# Convert the ebuild version to the upstream mozilla version, used by mozlinguas
+MOZ_PV="${PV/_beta/b}" # Handle beta for SRC_URI
+MOZ_PV="${MOZ_PV/_rc/rc}" # Handle rc for SRC_URI
+MOZ_PN="${PN/-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
+# Upstream ftp release URI that's used by mozlinguas.eclass
+MOZ_FTP_URI="http://mozilla.cdn.leaseweb.com/${MOZ_PN}/releases/"
+
+inherit eutils multilib pax-utils fdo-mime gnome2-utils mozlinguas nsplugins
+
+DESCRIPTION="Firefox Web Browser"
+SRC_URI="${SRC_URI}
+ ${MOZ_FTP_URI}/${MOZ_PV}/linux-x86_64/en-US/${MOZ_P}.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2
+ "
+HOMEPAGE="http://www.mozilla.com/firefox"
+RESTRICT="strip mirror binchecks"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
+IUSE="startup-notification"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ virtual/freedesktop-icon-theme
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+
+ >=x11-libs/gtk+-2.2:2
+ >=media-libs/alsa-lib-1.0.16
+"
+
+S="${WORKDIR}/${MOZ_PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ # Unpack language packs
+ mozlinguas_src_unpack
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/${MOZ_PN}
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ # Add StartupNotify=true bug 237317
+ if use startup-notification; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}.desktop
+ fi
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME} || die
+
+ # Fix prefs that make no sense for a system-wide install
+ insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
+ doins "${FILESDIR}"/${PN}-prefs.js || die
+
+ # Install language packs
+ mozlinguas_src_install
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ echo "pref(\"general.useragent.locale\", \"${LANG}\");" \
+ >> "${D}${MOZILLA_FIVE_HOME}"/defaults/pref/${PN}-prefs.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox-bin
+ dodir /usr/bin/
+ cat <<-EOF >"${D}"/usr/bin/${PN}
+ #!/bin/sh
+ unset LD_PRELOAD
+ LD_LIBRARY_PATH="/opt/firefox/"
+ GTK_PATH=/usr/lib/gtk-2.0/
+ exec /opt/${MOZ_PN}/${MOZ_PN} "\$@"
+ EOF
+ fperms 0755 /usr/bin/${PN}
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10${PN} || die
+
+ # Plugins dir
+ share_plugins_dir
+
+ # Required in order to use plugins and even run firefox on hardened.
+ pax-mark mr "${ED}"/${MOZILLA_FIVE_HOME}/{firefox,firefox-bin,plugin-container}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ # Drop requirement of curl not built with nss as it's not necessary anymore
+ #if has_version 'net-misc/curl[nss]'; then
+ # einfo
+ # einfo "Crashreporter won't be able to send reports"
+ # einfo "if you have curl emerged with the nss USE-flag"
+ # einfo
+ #fi
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}