summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/flush/ChangeLog7
-rw-r--r--net-p2p/flush/Manifest4
-rw-r--r--net-p2p/flush/flush-0.9.2.ebuild47
-rw-r--r--net-p2p/flush/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/flush/ChangeLog b/net-p2p/flush/ChangeLog
new file mode 100644
index 0000000..5438696
--- /dev/null
+++ b/net-p2p/flush/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-p2p/flush
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+
+*flush-0.9.2 (11 Apr 2010)
+ 11 Apr 2010; Iskren Slavov <iskren.s@gmail.com>
+ +flush-0.9.2.ebuild:
+ Initial release.
diff --git a/net-p2p/flush/Manifest b/net-p2p/flush/Manifest
new file mode 100644
index 0000000..0d3a83b
--- /dev/null
+++ b/net-p2p/flush/Manifest
@@ -0,0 +1,4 @@
+DIST flush-0.9.2.tar.bz2 784602 RMD160 8e0bd8c02dec9b4d4c8150ca2eec5114913cdc01 SHA1 439fa77eefeb8e7e2f8408883b915728bb4acf49 SHA256 4672856412337d3cd0a7201fec1927bae395a51e9bf55925cdf3210adc21df99
+EBUILD flush-0.9.2.ebuild 1047 RMD160 fd339934ed70addedd5c5616df1e6e2dc71a1523 SHA1 e37ae049c71fb58b3c32ca5644ec233a469175de SHA256 f04275bcb9e7177a181e3ca0c9a6a7f1c682386f739bbd469317944fad796066
+MISC ChangeLog 220 RMD160 c0c1b9468521d2c36df2deac157fb0a145f45a27 SHA1 9ff3d1eb5da9c216a0a96314d89aaef78abe8213 SHA256 38c682ce5d4aad90e36bfba63b4218ab3a0aab917a096629eedf0116014d1e90
+MISC metadata.xml 347 RMD160 70b0df4eab68c6e2a236386a3efb19411a0c1a4f SHA1 bdb761f41dba7b31f17d90149586620dd043e1af SHA256 d6b06d5ddb6dbec5ed402049e8aa8663aa85cfa6210990388254a363953df6f7
diff --git a/net-p2p/flush/flush-0.9.2.ebuild b/net-p2p/flush/flush-0.9.2.ebuild
new file mode 100644
index 0000000..8a7019c
--- /dev/null
+++ b/net-p2p/flush/flush-0.9.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="A GTK-based BitTorrent client by Dmitry Konishchev"
+HOMEPAGE="http://sourceforge.net/projects/flush/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.16.6
+ >=dev-cpp/gtkmm-2.16.0
+ >=dev-cpp/glibmm-2.20.1
+ >=x11-libs/libnotify-0.4.5
+
+ >=sys-devel/gettext-0.17
+ >=dev-libs/libconfig-1.3.2
+ >=dev-libs/boost-1.35.0
+ >=sys-apps/dbus-1.2.3
+
+ >=net-libs/rb_libtorrent-0.14.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --disable-bundle-package \
+ --enable-system-libconfig \
+ --enable-system-libtorrent
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc COPYING ChangeLog
+
+ # Fix icon if using different icon theme in GNOME
+ insinto /usr/share/pixmaps
+ doins ./icons/hicolor/72x72/apps/flush.png
+}
diff --git a/net-p2p/flush/metadata.xml b/net-p2p/flush/metadata.xml
new file mode 100644
index 0000000..820f469
--- /dev/null
+++ b/net-p2p/flush/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>iskren.s@gmail.com</email>
+</maintainer>
+<longdescription>Adobe Photoshop CS4 Colour Profiles. These are used if you'd like to
+have CMYK in GIMP.
+</longdescription>
+</pkgmetadata>