summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2011-03-10 23:52:55 -0600
committerDavid Phillips <write2david@gmail.com>2011-03-10 23:52:55 -0600
commit4e0efe7f8017fb3a0a858029c5a9e72843ce2599 (patch)
tree28883d0a46f31ab114ffb5b599dc8ef6be1eddc6
parentAdding temerge, version 0.47 (diff)
downloadwrite2David-4e0efe7f8017fb3a0a858029c5a9e72843ce2599.tar.gz
write2David-4e0efe7f8017fb3a0a858029c5a9e72843ce2599.tar.bz2
write2David-4e0efe7f8017fb3a0a858029c5a9e72843ce2599.zip
Adding easystroke
-rw-r--r--x11-misc/easystroke/Manifest3
-rw-r--r--x11-misc/easystroke/easystroke-0.5.4.ebuild36
-rw-r--r--x11-misc/easystroke/metadata.xml10
3 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/easystroke/Manifest b/x11-misc/easystroke/Manifest
new file mode 100644
index 0000000..8a946a7
--- /dev/null
+++ b/x11-misc/easystroke/Manifest
@@ -0,0 +1,3 @@
+DIST easystroke-0.5.4.tar.gz 103111 RMD160 55aadba296577f599588cdd792a970914b34b0b5 SHA1 25ac617f4b8a2b804738a8749e96e379c95ea691 SHA256 b18cd209248b1a6bcaa8bba42fe85b82e117cdb78d1b57ba3f5e2308cb3a5f64
+EBUILD easystroke-0.5.4.ebuild 1053 RMD160 87c840d4fe7f9c134cc440ea597da63939a08598 SHA1 4d7840f51cf49d593308f448e24e0eb5a5afd06e SHA256 5101a7eb491d4a4fa3e684ce2bfbd3c3a6463cd15d0232f4c68c11ca1910c727
+MISC metadata.xml 318 RMD160 1a77829ca0a3de9847cded7f27e1a6949951c1e7 SHA1 c12224d9f577f7dbb2a63f84a1ba4909a14a1f42 SHA256 7993a8933dc735a5fe2ba03d0ed83c1128489f0961da0ebf5e05b6e3725d013f
diff --git a/x11-misc/easystroke/easystroke-0.5.4.ebuild b/x11-misc/easystroke/easystroke-0.5.4.ebuild
new file mode 100644
index 0000000..b4be3f2
--- /dev/null
+++ b/x11-misc/easystroke/easystroke-0.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Temporarily adding to write2David overlay until someone official can put it in
+# the sunrise or Portage tree. Bug #253783.
+
+inherit eutils
+
+DESCRIPTION="Easystroke is a gesture-recognition application for X11."
+HOMEPAGE="http://easystroke.wiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm
+ x11-libs/libXrandr
+ x11-apps/xinput
+ x11-libs/libXtst
+ dev-libs/boost
+ dev-libs/dbus-glib
+ dev-util/intltool"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ sed -i "s/^LDFLAGS/#LDFLAGS/" Makefile || die "sed Makefile failed!"
+ sed -i "s!^Icon=easystroke!Icon=/usr/share/icons/hicolor/scalable/apps/easystroke.svg!" easystroke.desktop.in || die "sed easystroke.desktop.in failed!"
+ emake DESTDIR="${D}" PREFIX="/usr/" || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed!"
+}
diff --git a/x11-misc/easystroke/metadata.xml b/x11-misc/easystroke/metadata.xml
new file mode 100644
index 0000000..669ceec
--- /dev/null
+++ b/x11-misc/easystroke/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+ <maintainer>
+ <email>none</email>
+ </maintainer>
+
+ <longdescription>Easystroke is a gesture-recognition application for X11.</longdescription>
+</pkgmetadata>