summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2010-12-28 23:21:37 +0100
committerOlivier Huber <huber@crans.org>2010-12-28 23:21:37 +0100
commit9e9a8f10ab3ba246c8973569af003c46ba0b0ade (patch)
treeecb86e72f17e3a67685bf0a3f6d5eef031af9c27
parent[glMLite] fix Manifest (diff)
downloadxhub-9e9a8f10ab3ba246c8973569af003c46ba0b0ade.tar.gz
xhub-9e9a8f10ab3ba246c8973569af003c46ba0b0ade.tar.bz2
xhub-9e9a8f10ab3ba246c8973569af003c46ba0b0ade.zip
[ocaml-text] initial import
-rw-r--r--dev-ml/ocaml-text/Manifest2
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.4.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/Manifest b/dev-ml/ocaml-text/Manifest
new file mode 100644
index 0000000..4488724
--- /dev/null
+++ b/dev-ml/ocaml-text/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-text-0.4.tar.gz 240358 RMD160 94d5d381dab5ee2f7a916ad9e9be3a9b5695252b SHA1 77676eee5286c775144e59dee126377b61282602 SHA256 1837f3eb4e823e0c332ff96c6873795c804bd6c5e9604262d1510ca8999e0f31
+EBUILD ocaml-text-0.4.ebuild 854 RMD160 4c2abb280145ce68735b51691357f4e1bfb0de2e SHA1 25245ff3b0a762a38c9fd8c00ee323fbc6804ccc SHA256 48db25d80c975016e915d69fa0a85c8713d3ceb18f40319b951a5a8a6a0c15cd
diff --git a/dev-ml/ocaml-text/ocaml-text-0.4.ebuild b/dev-ml/ocaml-text/ocaml-text-0.4.ebuild
new file mode 100644
index 0000000..4c95a09
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit multilib findlib
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="https://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/537/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt pcre"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+virtual/libiconv
+pcre? ( dev-ml/pcre-ocaml[ocamlopt?] )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ ./configure --prefix "${EPREFIX}"/usr \
+ --mandir "${EPREFIX}"/usr/share/man \
+ --infodir "${EPREFIX}"/usr/share/info \
+ --datadir "${EPREFIX}"/usr/share \
+ --sysconfdir "${EPREFIX}"/etc \
+ --localstatedir "${EPREFIX}"/var/lib \
+ --libdir $(get_libdir) \
+ $(use_enable pcre)
+}
+
+src_install() {
+ findlib_src_install
+}