summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-08-01 09:12:49 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-08-01 09:12:49 +0000
commit7f70ea9aa91c6e0e153e3fed30c717a53684a938 (patch)
treeb8042402bb01852ad4b6c50d05b2354a39397977
parentversion bump by A. Person in bug #515602 (diff)
downloadgentoo-2-7f70ea9aa91c6e0e153e3fed30c717a53684a938.tar.gz
gentoo-2-7f70ea9aa91c6e0e153e3fed30c717a53684a938.tar.bz2
gentoo-2-7f70ea9aa91c6e0e153e3fed30c717a53684a938.zip
fix installation on PaX kernels (thanks to yangjay)
(Portage version: 2.2.10_p40/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/ghc-7.6.3-r1.ebuild15
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild13
3 files changed, 14 insertions, 20 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 5b283617c949..879dac041a91 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.261 2014/07/30 13:20:16 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.262 2014/08/01 09:12:49 slyfox Exp $
+
+ 01 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.6.3-r1.ebuild,
+ ghc-7.8.3.ebuild:
+ fix installation on PaX kernels (thanks to yangjay)
30 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.8.3.ebuild:
Fix pax-marking command for final ghc binary.
diff --git a/dev-lang/ghc/ghc-7.6.3-r1.ebuild b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
index 56f8302fcd95..16e38a504686 100644
--- a/dev-lang/ghc/ghc-7.6.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.12 2014/07/05 15:40:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.13 2014/08/01 09:12:49 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -604,10 +604,10 @@ src_compile() {
# but let users screw it by setting 'I_DEMAND_MY_CORES_LOADED'
# 4 parallel jobs usually does not break
- # 1. build compiler binary(+wrapper) first
- emake $(limit_jobs 4) inplace/bin/ghc-stage2 V=1
+ # 1. build compiler binary first
+ emake $(limit_jobs 4) ghc/stage2/build/tmp/ghc-stage2 V=1
# 2. pax-mark (bug #516430)
- pax-mark -m inplace/lib/ghc-stage2
+ pax-mark -m ghc/stage2/build/tmp/ghc-stage2
# 3. and then all the rest
emake $(limit_jobs 4) all V=1
@@ -726,16 +726,11 @@ src_install() {
DESTDIR="${D}" \
|| die "make ${insttarget} failed"
- # remove wrapper and linker
+ # remove wrapper and link
rm -f "${ED}"/usr/bin/haddock*
add-c_nonshared-to-ghci-libs
- # ghci uses mmap with rwx protection at it implements dynamic
- # linking on it's own (bug #299709)
- # so mark resulting binary
- pax-mark -m "${ED}/usr/$(get_libdir)/${P}/ghc"
-
if [[ ! -f "${S}/VERSION" ]]; then
echo "${GHC_PV}" > "${S}/VERSION" \
|| die "Could not create file ${S}/VERSION"
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index adbfdab1b83d..f2a21154c00c 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.4 2014/07/30 13:20:16 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.5 2014/08/01 09:12:49 slyfox Exp $
EAPI=5
@@ -489,10 +489,10 @@ src_configure() {
src_compile() {
if ! use binary; then
- # 1. build compiler binary(+wrapper) first
- emake inplace/bin/ghc-stage2
+ # 1. build compiler binary first
+ emake ghc/stage2/build/tmp/ghc-stage2
# 2. pax-mark (bug #516430)
- pax-mark -m inplace/lib/bin/ghc-stage2
+ pax-mark -m ghc/stage2/build/tmp/ghc-stage2
# 3. and then all the rest
emake all
fi # ! use binary
@@ -525,11 +525,6 @@ src_install() {
# remove link, but leave 'haddock-${GHC_P}'
rm -f "${ED}"/usr/bin/haddock
- # ghci uses mmap with rwx protection at it implements dynamic
- # linking on it's own (bug #299709)
- # so mark resulting binary
- pax-mark -m "${ED}/usr/$(get_libdir)/${GHC_P}/bin/ghc"
-
if [[ ! -f "${S}/VERSION" ]]; then
echo "${GHC_PV}" > "${S}/VERSION" \
|| die "Could not create file ${S}/VERSION"