summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-09-26 03:23:09 +0000
committerNaohiro Aota <naota@gentoo.org>2012-09-26 03:23:09 +0000
commit6e001cefb6b9ce46b3f1663b1b7555eaceea2e34 (patch)
treeb33bf34040a3bd0f301ab7d7d8d4d098aee4178f /app-i18n/scim-anthy
parentStable for HPPA (bug #435754). (diff)
downloadgentoo-2-6e001cefb6b9ce46b3f1663b1b7555eaceea2e34.tar.gz
gentoo-2-6e001cefb6b9ce46b3f1663b1b7555eaceea2e34.tar.bz2
gentoo-2-6e001cefb6b9ce46b3f1663b1b7555eaceea2e34.zip
Force scim not to use gtk3.
(Portage version: 2.2.0_alpha127/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-anthy')
-rw-r--r--app-i18n/scim-anthy/ChangeLog7
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild15
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild17
3 files changed, 22 insertions, 17 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index 0e4cc11bdd7b..bc6d03992420 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/scim-anthy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.62 2012/05/03 19:24:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.63 2012/09/26 03:23:09 naota Exp $
+
+ 26 Sep 2012; <naota@gentoo.org> scim-anthy-1.2.6.ebuild,
+ scim-anthy-1.2.7.ebuild, scim-anthy-1.3.1.ebuild:
+ Force scim not to use gtk3.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> scim-anthy-1.2.6.ebuild,
scim-anthy-1.2.7.ebuild, scim-anthy-1.3.1.ebuild:
@@ -276,4 +280,3 @@
30 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+scim-anthy-0.2.0.ebuild:
Initial import.
-
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
index 44bcd1038367..6b627769c94f 100644
--- a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.4 2012/05/03 19:24:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.5 2012/09/26 03:23:09 naota Exp $
-EAPI="1"
+EAPI="2"
inherit libtool
@@ -25,17 +25,18 @@ DEPEND="${DEPEND}
nls? ( sys-devel/gettext )
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
elibtoolize
}
-src_compile() {
+src_configure() {
econf \
$(use_enable nls) \
--disable-static \
- --disable-dependency-tracking
+ --disable-dependency-tracking || die
+}
+
+src_compile() {
emake || die "emake failed"
}
diff --git a/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
index b1869ced9603..e02c0b1d14dc 100644
--- a/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
+++ b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild,v 1.5 2012/05/03 19:24:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild,v 1.6 2012/09/26 03:23:09 naota Exp $
-EAPI="1"
+EAPI="2"
inherit libtool
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="gtk nls"
-DEPEND=">=app-i18n/scim-1.2
+DEPEND=">=app-i18n/scim-1.2[-gtk3]
|| ( >=app-i18n/anthy-7500 >=app-i18n/anthy-ss-7500 )
nls? ( virtual/libintl )
gtk? ( >=x11-libs/gtk+-2.8:2 )"
@@ -25,17 +25,18 @@ DEPEND="${DEPEND}
nls? ( sys-devel/gettext )
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
elibtoolize
}
-src_compile() {
+src_configure() {
econf \
$(use_enable nls) \
--disable-static \
- --disable-dependency-tracking
+ --disable-dependency-tracking || die
+}
+
+src_compile() {
emake || die "emake failed"
}