summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2006-11-25 13:21:35 +0000
committerJurek Bartuszek <jurek@gentoo.org>2006-11-25 13:21:35 +0000
commitb42c6351da94c171ad856c6f7257ab2acf5aa3c2 (patch)
tree9520ad73561e815378e8fb440e219f8ed16ca780 /app-laptop/acerhk
parentThere is NO stable for x86-fbsd! (diff)
downloadgentoo-2-b42c6351da94c171ad856c6f7257ab2acf5aa3c2.tar.gz
gentoo-2-b42c6351da94c171ad856c6f7257ab2acf5aa3c2.tar.bz2
gentoo-2-b42c6351da94c171ad856c6f7257ab2acf5aa3c2.zip
Added patch by Berke Viktor <bervik@citromail.hu> that allows app-laptop/acerhk to build against kernel version 2.6.19
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-laptop/acerhk')
-rw-r--r--app-laptop/acerhk/ChangeLog9
-rw-r--r--app-laptop/acerhk/acerhk-0.5.31.ebuild10
-rw-r--r--app-laptop/acerhk/acerhk-0.5.33.ebuild10
-rw-r--r--app-laptop/acerhk/acerhk-0.5.34.ebuild10
-rw-r--r--app-laptop/acerhk/files/kernel-2.6.19-config.h.patch26
5 files changed, 61 insertions, 4 deletions
diff --git a/app-laptop/acerhk/ChangeLog b/app-laptop/acerhk/ChangeLog
index 84870689551f..dd21626f9608 100644
--- a/app-laptop/acerhk/ChangeLog
+++ b/app-laptop/acerhk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/acerhk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/ChangeLog,v 1.18 2006/10/30 19:40:54 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/ChangeLog,v 1.19 2006/11/25 13:21:35 jurek Exp $
+
+ 25 Nov 2006; Jurek Bartuszek <jurek@gentoo.org>
+ +files/kernel-2.6.19-config.h.patch, acerhk-0.5.31.ebuild,
+ acerhk-0.5.33.ebuild, acerhk-0.5.34.ebuild:
+ Added patch written by Berke Viktor <bervik@citromail.hu> that allows
+ building acerhk against kernel 2.6.19 (include/linux/config.h was removed in
+ that release)
30 Oct 2006; Christian Faulhammer <opfer@gentoo.org> acerhk-0.5.33.ebuild:
stable x86 as requested in bug #153000
diff --git a/app-laptop/acerhk/acerhk-0.5.31.ebuild b/app-laptop/acerhk/acerhk-0.5.31.ebuild
index e319a7313d8b..4903f0f59d14 100644
--- a/app-laptop/acerhk/acerhk-0.5.31.ebuild
+++ b/app-laptop/acerhk/acerhk-0.5.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.31.ebuild,v 1.2 2006/05/14 23:43:12 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.31.ebuild,v 1.3 2006/11/25 13:21:35 jurek Exp $
inherit linux-mod
@@ -15,6 +15,14 @@ IUSE=""
MODULE_NAMES="acerhk(extra:)"
BUILD_TARGETS="all"
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/kernel-2.6.19-config.h.patch || die "epatch failed"
+}
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
diff --git a/app-laptop/acerhk/acerhk-0.5.33.ebuild b/app-laptop/acerhk/acerhk-0.5.33.ebuild
index d15d51e6ed69..fbeb100b2037 100644
--- a/app-laptop/acerhk/acerhk-0.5.33.ebuild
+++ b/app-laptop/acerhk/acerhk-0.5.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.33.ebuild,v 1.2 2006/10/30 19:40:54 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.33.ebuild,v 1.3 2006/11/25 13:21:35 jurek Exp $
inherit linux-mod
@@ -15,6 +15,14 @@ IUSE=""
MODULE_NAMES="acerhk(extra:)"
BUILD_TARGETS="all"
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/kernel-2.6.19-config.h.patch || die "epatch failed"
+}
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
diff --git a/app-laptop/acerhk/acerhk-0.5.34.ebuild b/app-laptop/acerhk/acerhk-0.5.34.ebuild
index 30d9a633f2f0..fbd3356696df 100644
--- a/app-laptop/acerhk/acerhk-0.5.34.ebuild
+++ b/app-laptop/acerhk/acerhk-0.5.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.34.ebuild,v 1.1 2006/10/27 17:41:03 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.34.ebuild,v 1.2 2006/11/25 13:21:35 jurek Exp $
inherit linux-mod
@@ -15,6 +15,14 @@ IUSE=""
MODULE_NAMES="acerhk(extra:)"
BUILD_TARGETS="all"
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/kernel-2.6.19-config.h.patch || die "epatch failed"
+}
+
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
diff --git a/app-laptop/acerhk/files/kernel-2.6.19-config.h.patch b/app-laptop/acerhk/files/kernel-2.6.19-config.h.patch
new file mode 100644
index 000000000000..747d2028ba4e
--- /dev/null
+++ b/app-laptop/acerhk/files/kernel-2.6.19-config.h.patch
@@ -0,0 +1,26 @@
+--- acerhk/acerhk.c 2006-10-22 23:14:47.000000000 +0200
++++ acerhk/acerhk.c 2006-10-22 23:15:05.000000000 +0200
+@@ -35,15 +35,20 @@
+ *
+ */
+
++#ifdef CONFIG_X86
++
++#include <linux/version.h>
++
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
++#include <linux/autoconf.h>
++#else
+ #include <linux/config.h>
++#endif
+
+ /* This driver is heavily dependent on the architecture, don't let anyone
+ * without an X86 machine use it. I doubt that there are laptops out there
+ * which would need this driver and are not X86, so it doesn't matter anyway.
+ */
+-#ifdef CONFIG_X86
+-
+-#include <linux/version.h>
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
+ #define KERNEL26