summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 23:40:28 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 23:40:28 +0000
commit19af09d0cd9f90ed508e1b973533c9b8d1b8fa1b (patch)
tree1ee14e5b26bde5fe3b837afc653fa47e0114ae8b /app-office
parentChanged unpack||die to unpack (diff)
downloadgentoo-2-19af09d0cd9f90ed508e1b973533c9b8d1b8fa1b.tar.gz
gentoo-2-19af09d0cd9f90ed508e1b973533c9b8d1b8fa1b.tar.bz2
gentoo-2-19af09d0cd9f90ed508e1b973533c9b8d1b8fa1b.zip
Changed econf||die to econf
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/lyx-1.2.1.ebuild14
-rw-r--r--app-office/mrproject/mrproject-0.6.ebuild12
-rw-r--r--app-office/scribus/scribus-0.8.ebuild17
-rw-r--r--app-office/scribus/scribus-0.9.2.ebuild18
4 files changed, 23 insertions, 38 deletions
diff --git a/app-office/lyx/lyx-1.2.1.ebuild b/app-office/lyx/lyx-1.2.1.ebuild
index 2725c1f82de7..634cc67156bc 100644
--- a/app-office/lyx/lyx-1.2.1.ebuild
+++ b/app-office/lyx/lyx-1.2.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.1.ebuild,v 1.8 2002/11/30 23:37:22 vapier Exp $
-IUSE="nls cups"
-
-S=${WORKDIR}/${P}
DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.gz"
HOMEPAGE="http://www.lyx.org/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.lyx.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="nls cups"
# This lyx-base ebuild only depends on the absolutely necessary packages.
# The acompanying lyx-utils ebuild depends on lyx-base and on everything
@@ -38,7 +36,6 @@ RDEPEND="${DEPEND}
app-text/chktex"
src_compile() {
-
use nls || myconf="${myconf} --disable-nls"
[ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
@@ -50,18 +47,17 @@ src_compile() {
#./autogen.sh
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
#--infodir='$(prefix)/share/info' \
#--with-extra-inc=/usr/X11R6/include \
#--mandir='$(prefix)/share/man' \
emake || die "emake failed"
}
-src_install () {
+src_install() {
# The 'install-strip' target is provided by the LyX makefile
# for stripping installed binaries. Use prefix= instead of
# DESTDIR=, otherwise it violates the sandbox in the po directory.
- einstall || die
+ einstall
dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
}
-
diff --git a/app-office/mrproject/mrproject-0.6.ebuild b/app-office/mrproject/mrproject-0.6.ebuild
index 6d4fa78e393d..2c193ffffab3 100644
--- a/app-office/mrproject/mrproject-0.6.ebuild
+++ b/app-office/mrproject/mrproject-0.6.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mrproject/mrproject-0.6.ebuild,v 1.3 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mrproject/mrproject-0.6.ebuild,v 1.4 2002/11/30 23:37:54 vapier Exp $
-IUSE="doc nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Project manager for Gnome2"
SRC_URI="ftp://ftp.codefactory.se/pub/software/mrproject/source/${P}.tar.gz"
HOMEPAGE="http://mrproject.codefactory.se/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://mrproject.codefactory.se/"
SLOT="2"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="doc nls"
RDEPEND=">=x11-libs/gtk+-2.0.5
>=x11-libs/pango-1.0.3
@@ -26,18 +24,16 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
src_compile() {
local myconf
use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
use nls && myconf="${myconf} --enable-nls" || myconf="${myconf} --disable-nls"
-
- econf ${myconf} --disable-maintainer-mode || die "compile failure"
+
+ econf ${myconf} --disable-maintainer-mode
emake || die
}
src_install() {
einstall
dodoc AUTHORS COPYING ChangeL* INSTALL NEWS README*
-
}
diff --git a/app-office/scribus/scribus-0.8.ebuild b/app-office/scribus/scribus-0.8.ebuild
index fc2c1bbf6f3d..645e6ba2cc2b 100644
--- a/app-office/scribus/scribus-0.8.ebuild
+++ b/app-office/scribus/scribus-0.8.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.8.ebuild,v 1.4 2002/11/28 22:17:14 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.8.ebuild,v 1.5 2002/11/30 23:38:46 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Scribus is a Layout program"
HOMEPAGE="http://web2.altmuehlnet.de/fschmid"
SRC_URI="http://web2.altmuehlnet.de/fschmid/${P}.tar.gz"
-IUSE="kde"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
+IUSE="kde"
DEPEND="=x11-libs/qt-3*
media-libs/freetype
@@ -26,20 +25,18 @@ src_unpack() {
}
src_compile() {
- econf || die "./configure failed"
+ econf
emake || die "make failed"
mv debian/scribus-debian.xpm debian/scribus.xpm
}
-src_install () {
-
- einstall destdir=${D} || die "couldn't be installed"
+src_install() {
+ einstall destdir=${D}
dodoc AUTHORS ChangeLog README TODO
# Fixing desktop.scribus
- use kde &&
- (
+ if [ `use kde` ] ; then
inherit kde-functions
set-kdedir 3
sed -e 's/local\///' desktop.scribus > desktop.scribus.2
@@ -47,7 +44,7 @@ src_install () {
cp -f desktop.scribus.2 scribus.desktop
insinto ${PREFIX}/share/applnk/Graphics
doins scribus.desktop
- )
+ fi
# Copy the pixmaps to the generic place
insinto /usr/share/pixmaps/
doins debian/scribus.xpm
diff --git a/app-office/scribus/scribus-0.9.2.ebuild b/app-office/scribus/scribus-0.9.2.ebuild
index a1645bf1f5d4..e3ebcb64bc20 100644
--- a/app-office/scribus/scribus-0.9.2.ebuild
+++ b/app-office/scribus/scribus-0.9.2.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.9.2.ebuild,v 1.2 2002/11/28 22:17:14 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-0.9.2.ebuild,v 1.3 2002/11/30 23:39:21 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Scribus is a Layout program"
HOMEPAGE="http://web2.altmuehlnet.de/fschmid"
SRC_URI="http://web2.altmuehlnet.de/fschmid/${P}.tar.gz"
-IUSE="kde"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
+IUSE="kde"
DEPEND="=x11-libs/qt-3*
media-libs/freetype
@@ -20,20 +19,18 @@ DEPEND="=x11-libs/qt-3*
CXXFLAGS="${CXXFLAGS} -I/usr/include/lcms"
src_compile() {
- econf || die "./configure failed"
+ econf
emake || die "make failed"
mv debian/scribus-debian.xpm debian/scribus.xpm
}
-src_install () {
-
- einstall destdir=${D} || die "couldn't be installed"
+src_install() {
+ einstall destdir=${D}
dodoc AUTHORS ChangeLog README TODO
# Fixing desktop.scribus
- use kde &&
- (
+ if [ `use kde` ] ; then
inherit kde-functions
set-kdedir 3
sed -e 's/local\///' desktop.scribus > desktop.scribus.2
@@ -41,11 +38,10 @@ src_install () {
cp -f desktop.scribus.2 scribus.desktop
insinto ${PREFIX}/share/applnk/Graphics
doins scribus.desktop
- )
+ fi
# Copy the pixmaps to the generic place
insinto /usr/share/pixmaps/
doins debian/scribus.xpm
dosym /usr/share/scribus/doc /usr/share/doc/${PF}/html
-
}