summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-05-19 00:43:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-05-19 00:43:47 +0000
commit626b345f5b6e2626a9cef1239b56eae15506659f (patch)
tree9cc89270ee604fb17beaddde5439c94fa72287d1 /app-pda
parentUpdate bluez dependancies per bug #269440. (diff)
downloadgentoo-2-626b345f5b6e2626a9cef1239b56eae15506659f.tar.gz
gentoo-2-626b345f5b6e2626a9cef1239b56eae15506659f.tar.bz2
gentoo-2-626b345f5b6e2626a9cef1239b56eae15506659f.zip
Fix up pilot-link libusb usage for libusb-compat. Minor patch for usb_open usage.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog9
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-libusb-compat-usb_open.patch21
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild7
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild7
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3.ebuild7
5 files changed, 44 insertions, 7 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index bbae5afdd28a..95e0535c53f0 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/pilot-link
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.49 2009/05/19 00:28:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.50 2009/05/19 00:43:47 robbat2 Exp $
+
+ 19 May 2009; Robin H. Johnson <robbat2@gentoo.org>
+ pilot-link-0.12.3.ebuild, pilot-link-0.12.3-r1.ebuild,
+ pilot-link-0.12.3-r2.ebuild,
+ +files/pilot-link-0.12.3-libusb-compat-usb_open.patch:
+ Fix up pilot-link libusb usage for libusb-compat. Minor patch for usb_open
+ usage.
19 May 2009; Robin H. Johnson <robbat2@gentoo.org>
pilot-link-0.12.3.ebuild, pilot-link-0.12.3-r1.ebuild,
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-libusb-compat-usb_open.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-libusb-compat-usb_open.patch
new file mode 100644
index 000000000000..3f580c5af1e1
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-libusb-compat-usb_open.patch
@@ -0,0 +1,21 @@
+With libusb-compat, usb_open() calls must be checked for their return value, as
+NULL is now returned on failure.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar pilot-link-0.12.3.orig/libpisock/libusb.c pilot-link-0.12.3/libpisock/libusb.c
+--- pilot-link-0.12.3.orig/libpisock/libusb.c 2007-02-09 08:06:22.000000000 -0800
++++ pilot-link-0.12.3/libpisock/libusb.c 2009-05-18 17:32:16.316895284 -0700
+@@ -141,6 +141,12 @@
+
+ LOG((PI_DBG_DEV, PI_DBG_LVL_DEBUG, "%s: USB_handle=%p\n",
+ __FILE__, USB_handle));
++
++ if(USB_handle == NULL) {
++ LOG((PI_DBG_DEV, PI_DBG_LVL_DEBUG, "%s: Unable to open device.\n",
++ __FILE__));
++ continue;
++ }
+
+ data->ref = USB_handle;
+
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild
index c190e5f806f3..1791feab968d 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild,v 1.5 2009/05/19 00:28:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r1.ebuild,v 1.6 2009/05/19 00:43:47 robbat2 Exp $
EAPI=2
@@ -23,7 +23,7 @@ BOTH_DEPEND="virtual/libiconv
python? ( >=dev-lang/python-2.4.4-r4 )
png? ( >=media-libs/libpng-1.2.18-r1 )
readline? ( >=sys-libs/readline-5.2_p4 )
- usb? ( >=dev-libs/libusb-0.1.12 )
+ usb? ( virtual/libusb:0 )
bluetooth? ( || ( >=net-wireless/bluez-libs-3.10 net-wireless/bluez ) )"
DEPEND="${BOTH_DEPEND}
@@ -55,6 +55,9 @@ src_prepare() {
# Fix Glibc open without mode error
epatch "${FILESDIR}/${P}-glibc-open.patch"
+ # libusb-compat requires you to check the return value of usb_open!
+ epatch "${FILESDIR}/${P}-libusb-compat-usb_open.patch"
+
AT_M4DIR="m4" eautoreconf
}
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
index 1c1ef12a014a..cad7dd99a9f9 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.2 2009/05/19 00:28:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.3 2009/05/19 00:43:47 robbat2 Exp $
EAPI=2
@@ -23,7 +23,7 @@ BOTH_DEPEND="virtual/libiconv
python? ( >=dev-lang/python-2.4.4-r4 )
png? ( >=media-libs/libpng-1.2.18-r1 )
readline? ( >=sys-libs/readline-5.2_p4 )
- usb? ( >=dev-libs/libusb-0.1.12 )
+ usb? ( virtual/libusb:0 )
bluetooth? ( || ( >=net-wireless/bluez-libs-3.10 net-wireless/bluez ) )"
DEPEND="${BOTH_DEPEND}
@@ -57,6 +57,9 @@ src_prepare() {
# Respect JAVACFLAGS bug #267445
epatch "${FILESDIR}/${P}-respect-javacflags.patch"
+
+ # libusb-compat requires you to check the return value of usb_open!
+ epatch "${FILESDIR}/${P}-libusb-compat-usb_open.patch"
AT_M4DIR="m4" eautoreconf
}
diff --git a/app-pda/pilot-link/pilot-link-0.12.3.ebuild b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
index 8d87493dc8eb..a288073ae374 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.12 2009/05/19 00:28:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.13 2009/05/19 00:43:47 robbat2 Exp $
inherit perl-module java-pkg-opt-2 eutils autotools distutils
@@ -21,7 +21,7 @@ BOTH_DEPEND="virtual/libiconv
python? ( >=dev-lang/python-2.4.4-r4 )
png? ( >=media-libs/libpng-1.2.18-r1 )
readline? ( >=sys-libs/readline-5.2_p4 )
- usb? ( >=dev-libs/libusb-0.1.12 )
+ usb? ( =virtual/libusb-0* )
bluetooth? ( || ( >=net-wireless/bluez-libs-3.10 net-wireless/bluez ) )"
DEPEND="${BOTH_DEPEND}
@@ -55,6 +55,9 @@ src_unpack() {
# Upstream patch to fix 64-bit issues.
epatch "${FILESDIR}/${P}-int_types.patch"
+
+ # libusb-compat requires you to check the return value of usb_open!
+ epatch "${FILESDIR}/${P}-libusb-compat-usb_open.patch"
AT_M4DIR="m4" eautoreconf
}