summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 22:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 22:56:33 +0000
commit596b576430fcc73a6b68bbedb8231673f47cf255 (patch)
treeb13907cbb0b1011208572a96a33b604a1c1feb3c /app-text/htmltidy
parentsmall fix to conf.d entry (Manifest recommit) (diff)
downloadgentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.tar.gz
gentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.tar.bz2
gentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.zip
add inherit eutils
Diffstat (limited to 'app-text/htmltidy')
-rw-r--r--app-text/htmltidy/htmltidy-2.7.18-r2.ebuild18
-rw-r--r--app-text/htmltidy/htmltidy-3.10.29.ebuild20
2 files changed, 14 insertions, 24 deletions
diff --git a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
index e375099132c8..2f5f61ffd4a6 100644
--- a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
+++ b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.1 2003/12/20 05:23:52 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.2 2004/04/08 22:53:10 vapier Exp $
+
+inherit eutils
# convert from normalized gentoo version number to htmltidy's wacky date thing
parts=(${PV//./ })
@@ -9,36 +11,31 @@ MY_P=tidy_src_${vers}
S=${WORKDIR}/tidy
DESCRIPTION="Tidy the layout and correct errors in HTML and XML documents"
+HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz"
-HOMEPAGE="http://tidy.sourceforge.net/"
-LICENSE="GPL-2"
-IUSE="xml doc"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="xml doc"
DEPEND=""
src_unpack() {
-
unpack ${A}
cd ${S}
use xml && epatch ${FILESDIR}/htmltidy-dbpatch.diff
# Prevent tidy from chown/grp'ing itself to 'tidy:tidy'
sed -i -e "s:chgrp\|chown:#&:" Makefile
-
}
src_compile() {
-
emake OTHERCFLAGS="${CFLAGS}" || die "emake failed"
-
}
src_install() {
-
# Need to move the man page around, thanks to the flaky Makefile
cp ${S}/htmldoc/man_page.txt ${S}/man_page.txt
@@ -51,5 +48,4 @@ src_install() {
dohtml *.html *.gif *.css
# and the api documentation if we have USE="doc"
use doc && dohtml -r api
-
}
diff --git a/app-text/htmltidy/htmltidy-3.10.29.ebuild b/app-text/htmltidy/htmltidy-3.10.29.ebuild
index de1791a83766..caaf2fae5af1 100644
--- a/app-text/htmltidy/htmltidy-3.10.29.ebuild
+++ b/app-text/htmltidy/htmltidy-3.10.29.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.7 2004/02/27 21:19:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.8 2004/04/08 22:53:45 vapier Exp $
+
+inherit eutils
# Convert gentoo version number x.y.z to date xyz for
# tidy's source numbering by date
@@ -14,14 +16,13 @@ HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz
xml? ( http://www.cise.ufl.edu/~ppadala/tidy/html2db.tar.gz )"
-LICENSE="GPL-2"
-IUSE="debug doc xml"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~amd64"
+IUSE="debug doc xml"
src_unpack() {
-
unpack ${A}
cd ${S}
# Required to setup the source dist for autotools
@@ -32,7 +33,7 @@ src_unpack() {
# Stop tidy from appending -O2 to our CFLAGS
sed -i -e "/save_cflags/s/\ \-O2//" configure.in
- if [ `use xml` ]; then
+ if use xml ; then
# Apply the docbook patch to tidy sources
epatch ${FILESDIR}/03-${PN}-docbook.patch
@@ -44,26 +45,21 @@ src_unpack() {
sed -i -e "/TIDYDIR\=/s:\.\.:${S}:" \
-e "/LIBDIR\=/s:lib:src\/\.libs\/:" \
${WORKDIR}/html2db/Makefile
-
fi
-
}
src_compile() {
-
export WANT_AUTOMAKE=1.5 WANT_AUTOCONF=2.5
econf `use_enable debug` || die
emake || die
- if [ `use xml` ]; then
+ if use xml ; then
cd ${WORKDIR}/html2db
make || die
fi
-
}
src_install() {
-
make DESTDIR=${D} install || die
use xml && dobin ${WORKDIR}/html2db/html2db
@@ -79,6 +75,4 @@ src_install() {
# If use 'doc' is set, then we also want to install the
# api documentation
use doc && dohtml -r api
-
}
-