summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-01 09:56:06 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-01 09:56:06 +0000
commit6c7813bf3cb42efeeefaadeffc323fd75e9ab073 (patch)
treedd08ca12b67a161be1ca2fcd7bf1a325a042f974 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-6c7813bf3cb42efeeefaadeffc323fd75e9ab073.tar.gz
gentoo-2-6c7813bf3cb42efeeefaadeffc323fd75e9ab073.tar.bz2
gentoo-2-6c7813bf3cb42efeeefaadeffc323fd75e9ab073.zip
Use python-any-r1 to clearly enforce build-time Python dependency.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.5.4-r5.ebuild10
-rw-r--r--dev-lang/python/python-2.6.8-r1.ebuild12
-rw-r--r--dev-lang/python/python-2.7.3-r3.ebuild12
-rw-r--r--dev-lang/python/python-3.1.5-r1.ebuild10
-rw-r--r--dev-lang/python/python-3.2.3-r2.ebuild8
-rw-r--r--dev-lang/python/python-3.3.0-r1.ebuild8
7 files changed, 51 insertions, 16 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 71fdc20ef2d2..ab4b5df32d25 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.623 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.624 2012/12/01 09:56:06 mgorny Exp $
+
+ 01 Dec 2012; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
+ python-2.6.8-r1.ebuild, python-2.7.3-r3.ebuild, python-3.1.5-r1.ebuild,
+ python-3.2.3-r2.ebuild, python-3.3.0-r1.ebuild:
+ Use python-any-r1 to clearly enforce build-time Python dependency.
30 Nov 2012; Michał Górny <mgorny@gentoo.org> python-2.5.4-r5.ebuild,
python-2.6.8-r1.ebuild, python-2.7.3-r3.ebuild, python-3.1.5-r1.ebuild,
diff --git a/dev-lang/python/python-2.5.4-r5.ebuild b/dev-lang/python/python-2.5.4-r5.ebuild
index 10a15b6d26b8..2f9e0048fe6d 100644
--- a/dev-lang/python/python-2.5.4-r5.ebuild
+++ b/dev-lang/python/python-2.5.4-r5.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r5.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="1"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 2 requires Python 2.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
@@ -45,6 +48,7 @@ RDEPEND=">=sys-libs/zlib-1.1.3
)
doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig"
RDEPEND+=" !build? ( app-misc/mime-types )"
PDEPEND="app-admin/eselect-python
@@ -59,6 +63,8 @@ pkg_setup() {
ewarn "removed in Python 3. A maintained alternative of 'bsddb3' module"
ewarn "is provided by dev-python/bsddb3."
fi
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/dev-lang/python/python-2.6.8-r1.ebuild b/dev-lang/python/python-2.6.8-r1.ebuild
index 54f109996e9f..951bb2ca9f0c 100644
--- a/dev-lang/python/python-2.6.8-r1.ebuild
+++ b/dev-lang/python/python-2.6.8-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 2 requires Python 2.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="0"
@@ -49,6 +52,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"
@@ -72,6 +76,8 @@ pkg_setup() {
ewarn "You might need to migrate your databases."
fi
fi
+
+ python-any-r1_pkg_setup
}
src_prepare() {
@@ -183,7 +189,7 @@ src_configure() {
}
src_compile() {
- emake EPYTHON="python${PV%%.*}" || die "emake failed"
+ default
# Work around bug 329499. See also bug 413751.
pax-mark m python
diff --git a/dev-lang/python/python-2.7.3-r3.ebuild b/dev-lang/python/python-2.7.3-r3.ebuild
index fc0ae67165fb..361a8e630e53 100644
--- a/dev-lang/python/python-2.7.3-r3.ebuild
+++ b/dev-lang/python/python-2.7.3-r3.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r3.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="2"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 2 requires Python 2.
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="1"
@@ -50,6 +53,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
@@ -73,6 +77,8 @@ pkg_setup() {
ewarn "You might need to migrate your databases."
fi
fi
+
+ python-any-r1_pkg_setup
}
src_prepare() {
@@ -197,7 +203,7 @@ src_configure() {
}
src_compile() {
- emake EPYTHON="python${PV%%.*}" || die "emake failed"
+ default
# Work around bug 329499. See also bug 413751.
pax-mark m python
diff --git a/dev-lang/python/python-3.1.5-r1.ebuild b/dev-lang/python/python-3.1.5-r1.ebuild
index dd99c5e5eb94..f06675a5f83b 100644
--- a/dev-lang/python/python-3.1.5-r1.ebuild
+++ b/dev-lang/python/python-3.1.5-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 3 requires any Python version.
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="0"
@@ -40,6 +43,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"
@@ -162,7 +166,7 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ default
# Work around bug 329499. See also bug 413751.
pax-mark m python
diff --git a/dev-lang/python/python-3.2.3-r2.ebuild b/dev-lang/python/python-3.2.3-r2.ebuild
index 7a430b619011..93ee8dfc0965 100644
--- a/dev-lang/python/python-3.2.3-r2.ebuild
+++ b/dev-lang/python/python-3.2.3-r2.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r2.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 3 requires any Python version.
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="0"
@@ -40,6 +43,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
diff --git a/dev-lang/python/python-3.3.0-r1.ebuild b/dev-lang/python/python-3.3.0-r1.ebuild
index ea6a161b0efb..060dd8197a31 100644
--- a/dev-lang/python/python-3.3.0-r1.ebuild
+++ b/dev-lang/python/python-3.3.0-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.0-r1.ebuild,v 1.3 2012/12/01 09:56:06 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
+# Bootstrapping Python 3 requires any Python version.
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="1"
@@ -40,6 +43,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"