summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-22 14:23:51 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-22 14:23:51 +0000
commit23cf03d8ab3e47dac6135789d54bc53c39ac580e (patch)
tree273c662c3d72b5b51da503241988e8fecc055ad0 /dev-libs/libsmtp/libsmtp-0.8.ebuild
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.tar.gz
gentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.tar.bz2
gentoo-2-23cf03d8ab3e47dac6135789d54bc53c39ac580e.zip
Initial commit; needed for smtp support in dev-libs/log4cxx.
Diffstat (limited to 'dev-libs/libsmtp/libsmtp-0.8.ebuild')
-rw-r--r--dev-libs/libsmtp/libsmtp-0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libsmtp/libsmtp-0.8.ebuild b/dev-libs/libsmtp/libsmtp-0.8.ebuild
new file mode 100644
index 000000000000..e067c7aab676
--- /dev/null
+++ b/dev-libs/libsmtp/libsmtp-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsmtp/libsmtp-0.8.ebuild,v 1.1 2004/12/22 14:23:51 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A small C library that allows direct SMTP connections conforming to RFC 822"
+HOMEPAGE="http://libsmtp.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ dev-libs/glib"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_install() {
+ dolib.a smtp/libsmtp.a mime/libsmtp_mime.a || die "dolib.a failed"
+ dodoc AUTHORS CHANGES INSTALL README doc/API doc/BUGS doc/MIME doc/TODO \
+ || die "dodoc failed"
+
+ if use doc ; then
+ cd ${S}/examples
+ rm -fr CVS
+ make clean
+ docinto examples
+ dodoc *
+ fi
+}