summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-07-20 12:48:50 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-07-20 12:48:50 +0000
commitd8ea97deb9829b185b04eef76faa1a48bcb3491f (patch)
treedd9a9895d6b00e8a7492816847c886ea032b1e7c /dev-libs/opensc/opensc-0.11.2.ebuild
parentKeyworded ~sparc (diff)
downloadgentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.tar.gz
gentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.tar.bz2
gentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-libs/opensc/opensc-0.11.2.ebuild')
-rw-r--r--dev-libs/opensc/opensc-0.11.2.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-libs/opensc/opensc-0.11.2.ebuild b/dev-libs/opensc/opensc-0.11.2.ebuild
index 5d3cb8786736..f263381f317e 100644
--- a/dev-libs/opensc/opensc-0.11.2.ebuild
+++ b/dev-libs/opensc/opensc-0.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.2.ebuild,v 1.1 2007/07/20 11:38:00 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.2.ebuild,v 1.2 2007/07/20 12:48:50 alonbl Exp $
WANT_AUTOMAKE="1.9"
@@ -13,26 +13,33 @@ SRC_URI="http://www.opensc-project.org/files/opensc/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="pcsc-lite openct"
+IUSE="pcsc-lite openct nsplugin"
RDEPEND="dev-libs/openssl
sys-libs/zlib
openct? ( >=dev-libs/openct-0.5.0 )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ nsplugin? ( app-crypt/pinentry )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ nsplugin? ( dev-libs/libassuan )"
src_compile() {
- # --without-plugin-dir generates a /no directory
+ local ASSUAN_PREFIX="${T}"
+
# disable assuan stuff it create text realocation.
+ use nsplugin && ASSUAN_PREFIX=/usr
+
+ # --without-plugin-dir generates a /no directory
econf \
- --with-plugin-dir=/usr/lib/mozilla/plugins \
$(use_enable openct) \
$(use_enable pcsc-lite) \
- --with-libassuan-prefix="${T}" \
+ --with-plugin-dir=/usr/lib/mozilla/plugins \
+ --with-libassuan-prefix="${ASSUAN_PREFIX}" \
+ --with-pin-entry="/usr/bin/pinentry" \
|| die
- emake -j1 || die
+ emake || die
}
src_install() {