summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-10 11:55:24 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-10 11:55:24 +0000
commit035c067de98cc2049b495ff355f716744ff003a4 (patch)
treee3091d69d49987805e8749b51387c7bc386748c8 /dev-python/logilab-common
parentUse distutils_install_for_testing(). (diff)
downloadgentoo-2-035c067de98cc2049b495ff355f716744ff003a4.tar.gz
gentoo-2-035c067de98cc2049b495ff355f716744ff003a4.tar.bz2
gentoo-2-035c067de98cc2049b495ff355f716744ff003a4.zip
Use distutils_install_for_testing().
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog5
-rw-r--r--dev-python/logilab-common/logilab-common-0.59.0.ebuild27
2 files changed, 8 insertions, 24 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index 066b5084b2dc..717b73875496 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.121 2013/02/09 20:05:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.122 2013/02/10 11:55:24 mgorny Exp $
+
+ 10 Feb 2013; Michał Górny <mgorny@gentoo.org> logilab-common-0.59.0.ebuild:
+ Use distutils_install_for_testing().
09 Feb 2013; Mike Gilbert <floppym@gentoo.org>
-files/logilab-common-0.59.0-utf8-test.patch, logilab-common-0.59.0.ebuild:
diff --git a/dev-python/logilab-common/logilab-common-0.59.0.ebuild b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
index 962f5fb14c45..78d55fe5093f 100644
--- a/dev-python/logilab-common/logilab-common-0.59.0.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.59.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.6 2013/02/10 05:27:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.0.ebuild,v 1.7 2013/02/10 11:55:24 mgorny Exp $
EAPI=5
# broken with python3.3, bug #449276
@@ -51,33 +51,14 @@ python_compile_all() {
}
python_test() {
- # The package has to be 'installed' before testing.
- # 1) because of namespaces, we can't use 'install --root',
- # 2) 'install --home' is terribly broken on pypy,
- # 3) non-root 'install' complains about PYTHONPATH and missing dirs,
- # so we need to set it properly and mkdir them,
- # 4) it runs a bunch of commands which write random files to cwd,
- # in order to avoid that, we need to run them ourselves to pass
- # alternate build paths,
- # 5) 'install' needs to go before 'bdist_egg' or the latter would
- # re-set install paths.
-
- local tpath=${BUILD_DIR}/test
- local bindir=${tpath}/bin
- local libdir=${tpath}/lib
- local PYTHONPATH=${libdir}:${PYTHONPATH}
-
- mkdir -p "${libdir}" || die
- esetup.py egg_info --egg-base="${tpath}" \
- install --install-lib="${libdir}" --install-scripts="${bindir}" \
- bdist_egg --dist-dir="${tpath}"
+ distutils_install_for_testing
# Prevent timezone related failure.
export TZ=UTC
# Make sure that the tests use correct modules.
- cd "${libdir}" || die
- "${bindir}"/pytest || die "Tests fail with ${EPYTHON}"
+ cd "${TEST_DIR}"/lib || die
+ "${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
}
python_install_all() {