summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-15 19:19:27 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-15 19:19:27 +0000
commit942ad144dec741a87b622f5018468dc8c06bf102 (patch)
tree2d24399fcbfd173bb08fb81fc1b132f7f50d3bb1 /dev-python/manuel
parentAdd blocker against multilib-enabled motif. (diff)
downloadgentoo-2-942ad144dec741a87b622f5018468dc8c06bf102.tar.gz
gentoo-2-942ad144dec741a87b622f5018468dc8c06bf102.tar.bz2
gentoo-2-942ad144dec741a87b622f5018468dc8c06bf102.zip
ebuild written tested by me, required by testsuite of testfixtures
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/ChangeLog9
-rw-r--r--dev-python/manuel/files/manuel-1.7-rm_zope_test.patch92
-rw-r--r--dev-python/manuel/manuel-1.7.1.ebuild33
-rw-r--r--dev-python/manuel/metadata.xml8
4 files changed, 142 insertions, 0 deletions
diff --git a/dev-python/manuel/ChangeLog b/dev-python/manuel/ChangeLog
new file mode 100644
index 000000000000..2d7102884b63
--- /dev/null
+++ b/dev-python/manuel/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/manuel
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/ChangeLog,v 1.7 2013/03/15 19:19:27 idella4 Exp $
+
+*manuel-1.7.1 (15 Mar 2013)
+
+ 15 Mar 2013; Ian Delaney <idella4@gentoo.org>
+ +files/manuel-1.7-rm_zope_test.patch, +manuel-1.7.1.ebuild, +metadata.xml:
+ ebuild written tested by me, required by testsuite of testfixtures
diff --git a/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch b/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
new file mode 100644
index 000000000000..3487e5f9a9fa
--- /dev/null
+++ b/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
@@ -0,0 +1,92 @@
+diff -ur manuel-1.7.1.orig/src/manuel/tests.py manuel-1.7.1/src/manuel/tests.py
+--- src/manuel/tests.py 2012-04-17 03:08:54.000000000 +0800
++++ src/manuel/tests.py 2012-05-21 20:43:20.981722893 +0800
+@@ -9,16 +9,17 @@
+ import os.path
+ import re
+ import unittest
+-import zope.testing.renormalizing
+
+ doctest = manuel.absolute_import('doctest')
+
+ here = os.path.dirname(os.path.abspath(__file__))
+
+-checker = zope.testing.renormalizing.RENormalizing([
++try:
++ checker = zope.testing.renormalizing.RENormalizing([
+ (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
+ ])
+-
++except:
++ pass
+
+ def turtle_on_the_bottom_test():
+ """We use manuel to test itself.
+@@ -52,7 +53,6 @@
+ optionflags = doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS
+
+ m = manuel.ignore.Manuel()
+- m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
+ m += manuel.codeblock.Manuel()
+ m += manuel.capture.Manuel()
+ m += manuel.testcase.SectionManuel()
+@@ -66,3 +66,6 @@
+ suite,
+ doctest.DocTestSuite(),
+ ))
++
++if __name__ == '__main__':
++ unittest.TextTestRunner().run(test_suite())
+diff -ur manuel-1.7.1.orig/setup.py manuel-1.7.1/setup.py
+--- setup.py 2013-02-14 10:07:38.000000000 +0800
++++ setup.py 2013-03-15 23:21:18.834849031 +0800
+@@ -21,8 +21,6 @@
+ + open('CHANGES.txt').read()
+ )
+
+-tests_require = ['zope.testing']
+-
+ setup(
+ name='manuel',
+ version='1.7.1',
+@@ -38,10 +36,6 @@
+ 'Programming Language :: Python :: 3',
+ ],
+ license='ZPL',
+- extras_require={
+- 'tests': tests_require,
+- },
+- tests_require = tests_require,
+ test_suite = 'manuel.tests.test_suite',
+ install_requires=[
+ 'setuptools',
+diff -ur manuel-1.7.1.orig/src/manuel/index.txt manuel-1.7.1/src/manuel/index.txt
+--- src/manuel/index.txt 2012-04-17 03:08:54.000000000 +0800
++++ src/manuel/index.txt 2012-04-28 05:43:26.918993769 +0800
+@@ -166,16 +166,16 @@
+
+ .. code-block:: python
+
+- import os.path
+- import manuel.testing
++ import os.path
++ import manuel.testing
+
+- class StripDirsTestCase(manuel.testing.TestCase):
+- def shortDescription(self):
++ class StripDirsTestCase(manuel.testing.TestCase):
++ def shortDescription(self):
+ return os.path.basename(str(self))
+- suite = manuel.testing.TestSuite(
+- m, path_to_test, TestCase=StripDirsTestCase)
++ suite = manuel.testing.TestSuite(
++ m, path_to_test, TestCase=StripDirsTestCase)
+
+- >>> list(suite)[0].shortDescription()
++ list(suite)[0].shortDescription()
+ 'bugs.txt'
+
+
+
+
+
diff --git a/dev-python/manuel/manuel-1.7.1.ebuild b/dev-python/manuel/manuel-1.7.1.ebuild
new file mode 100644
index 000000000000..bd30064af75b
--- /dev/null
+++ b/dev-python/manuel/manuel-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/manuel/manuel-1.7.1.ebuild,v 1.1 2013/03/15 19:19:27 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} python{3_1,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation."
+HOMEPAGE="https://github.com/benji-york/manuel/ http://pypi.python.org/pypi/manuel"
+# A snapshot was required since upstream missed out half the source
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}-20130316.tar.bz2"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES.txt )
+
+src_prepare() {
+ # Extract all refs to and use of zope.testing
+ epatch "${FILESDIR}"/${PN}-1.7-rm_zope_test.patch
+}
+
+python_test() {
+ PYTHONPATH=${BUILD_DIR}/lib esetup.py test
+}
diff --git a/dev-python/manuel/metadata.xml b/dev-python/manuel/metadata.xml
new file mode 100644
index 000000000000..c3ddffdb091c
--- /dev/null
+++ b/dev-python/manuel/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+</pkgmetadata>