summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2008-05-25 20:23:51 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2008-05-25 20:23:51 +0000
commit50a67fad026295c40dcaf407dedc34d8a9f3ddd3 (patch)
treee97461f5c18bae7d205dadf4bb37ca11836c0d16 /dev-python/twisted
parentbump to 1.20.3 (just for the sake of it). win32 fixes. (diff)
downloadgentoo-2-50a67fad026295c40dcaf407dedc34d8a9f3ddd3.tar.gz
gentoo-2-50a67fad026295c40dcaf407dedc34d8a9f3ddd3.tar.bz2
gentoo-2-50a67fad026295c40dcaf407dedc34d8a9f3ddd3.zip
Version bump and minor fixes
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog8
-rw-r--r--dev-python/twisted/twisted-1.2.0.ebuild10
-rw-r--r--dev-python/twisted/twisted-1.3.0.ebuild8
-rw-r--r--dev-python/twisted/twisted-2.0.1.ebuild4
-rw-r--r--dev-python/twisted/twisted-2.1.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-2.2.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-2.4.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-2.5.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-8.1.0.ebuild108
9 files changed, 134 insertions, 20 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 0f3c8ca070bb..a7cbad6c730f 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.89 2008/05/13 20:29:16 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.90 2008/05/25 20:23:51 lordvan Exp $
+
+*twisted-8.1.0 (25 May 2008)
+
+ 25 May 2008; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.2.0.ebuild,
+ twisted-1.3.0.ebuild, +twisted-8.1.0.ebuild:
+ Version bump to 8.1.0 + some minor fixes to older ebuilds
*twisted-8.0.1 (13 May 2008)
diff --git a/dev-python/twisted/twisted-1.2.0.ebuild b/dev-python/twisted/twisted-1.2.0.ebuild
index a024e8b59900..22778e7bb62c 100644
--- a/dev-python/twisted/twisted-1.2.0.ebuild
+++ b/dev-python/twisted/twisted-1.2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.0.ebuild,v 1.14 2005/11/03 21:04:25 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.0.ebuild,v 1.15 2008/05/25 20:23:51 lordvan Exp $
inherit distutils
-DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+DESCRIPTION="An asynchronous networking framework written in Python"
HOMEPAGE="http://www.twistedmatrix.com/"
SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${PV}.tar.bz2"
@@ -20,7 +20,7 @@ DEPEND=">=dev-lang/python-2.2
gtk? ( >=dev-python/pygtk-1.99 )
doc? ( =dev-python/twisted-docs-${PV} )"
-S=${WORKDIR}/Twisted-${PV}
+S="${WORKDIR}/Twisted-${PV}"
src_install() {
distutils_src_install
@@ -29,6 +29,6 @@ src_install() {
if use gtk; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
- -i ${D}/usr/bin/manhole
+ -i '${D}/usr/bin/manhole'
fi
}
diff --git a/dev-python/twisted/twisted-1.3.0.ebuild b/dev-python/twisted/twisted-1.3.0.ebuild
index 10c692df6bd0..31ed8b33399e 100644
--- a/dev-python/twisted/twisted-1.3.0.ebuild
+++ b/dev-python/twisted/twisted-1.3.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.3.0.ebuild,v 1.11 2006/02/06 03:04:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.3.0.ebuild,v 1.12 2008/05/25 20:23:51 lordvan Exp $
inherit distutils
# for alphas,..
MY_PV="${PV/_alpha/alpha}"
-DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+DESCRIPTION="An asynchronous networking framework written in Python"
HOMEPAGE="http://www.twistedmatrix.com/"
SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${MY_PV}.tar.bz2"
@@ -31,6 +31,6 @@ src_install() {
if use gtk; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
- -i ${D}/usr/bin/manhole
+ -i '${D}/usr/bin/manhole'
fi
}
diff --git a/dev-python/twisted/twisted-2.0.1.ebuild b/dev-python/twisted/twisted-2.0.1.ebuild
index 7e7b65871576..137102a85c10 100644
--- a/dev-python/twisted/twisted-2.0.1.ebuild
+++ b/dev-python/twisted/twisted-2.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.0.1.ebuild,v 1.11 2006/06/30 23:01:56 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.0.1.ebuild,v 1.12 2008/05/25 20:23:51 lordvan Exp $
inherit eutils distutils versionator
diff --git a/dev-python/twisted/twisted-2.1.0.ebuild b/dev-python/twisted/twisted-2.1.0.ebuild
index 4ea8db86d353..9f8420796d46 100644
--- a/dev-python/twisted/twisted-2.1.0.ebuild
+++ b/dev-python/twisted/twisted-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.1.0.ebuild,v 1.8 2006/06/22 19:18:10 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.1.0.ebuild,v 1.9 2008/05/25 20:23:51 lordvan Exp $
inherit eutils distutils versionator
diff --git a/dev-python/twisted/twisted-2.2.0.ebuild b/dev-python/twisted/twisted-2.2.0.ebuild
index 0fec25f3577c..86597e200be7 100644
--- a/dev-python/twisted/twisted-2.2.0.ebuild
+++ b/dev-python/twisted/twisted-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.2.0.ebuild,v 1.8 2006/07/13 02:24:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.2.0.ebuild,v 1.9 2008/05/25 20:23:51 lordvan Exp $
inherit eutils distutils versionator
diff --git a/dev-python/twisted/twisted-2.4.0.ebuild b/dev-python/twisted/twisted-2.4.0.ebuild
index beb2ea6eee86..54b974c18cfb 100644
--- a/dev-python/twisted/twisted-2.4.0.ebuild
+++ b/dev-python/twisted/twisted-2.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.4.0.ebuild,v 1.11 2007/03/12 18:57:33 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.4.0.ebuild,v 1.12 2008/05/25 20:23:51 lordvan Exp $
inherit eutils distutils versionator
diff --git a/dev-python/twisted/twisted-2.5.0.ebuild b/dev-python/twisted/twisted-2.5.0.ebuild
index 964e97c7265f..a5108f60043d 100644
--- a/dev-python/twisted/twisted-2.5.0.ebuild
+++ b/dev-python/twisted/twisted-2.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.5.0.ebuild,v 1.2 2007/02/13 13:24:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.5.0.ebuild,v 1.3 2008/05/25 20:23:51 lordvan Exp $
inherit eutils distutils versionator
diff --git a/dev-python/twisted/twisted-8.1.0.ebuild b/dev-python/twisted/twisted-8.1.0.ebuild
new file mode 100644
index 000000000000..b79b28626c19
--- /dev/null
+++ b/dev-python/twisted/twisted-8.1.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-8.1.0.ebuild,v 1.1 2008/05/25 20:23:51 lordvan Exp $
+
+inherit eutils distutils versionator
+
+MY_P=TwistedCore-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/${PN}/Core/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.3
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99 )
+ !dev-python/twisted-docs"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="CREDITS NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Pass valid arguments to "head" in the zsh completion function.
+ epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ PYTHONPATH=. "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ cd "${S}"
+ rm -rf "${T}/tests"
+}