summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:28:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:28:05 +0000
commit72f972fc55d43bb6a8c5f30857f97c5e5656b49e (patch)
treec3afdc791a3e4a0f7975c231bc403a90b792db14 /dev-python
parentVersion bump (diff)
downloadgentoo-2-72f972fc55d43bb6a8c5f30857f97c5e5656b49e.tar.gz
gentoo-2-72f972fc55d43bb6a8c5f30857f97c5e5656b49e.tar.bz2
gentoo-2-72f972fc55d43bb6a8c5f30857f97c5e5656b49e.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fusil/ChangeLog10
-rw-r--r--dev-python/fusil/files/1.4-python25.patch12
-rw-r--r--dev-python/fusil/fusil-1.4.ebuild51
3 files changed, 71 insertions, 2 deletions
diff --git a/dev-python/fusil/ChangeLog b/dev-python/fusil/ChangeLog
index a8185989e13b..a3b4fb8e0fff 100644
--- a/dev-python/fusil/ChangeLog
+++ b/dev-python/fusil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fusil
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.6 2010/06/30 00:03:15 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.7 2011/07/29 22:28:05 bicatali Exp $
+
+*fusil-1.4 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/1.4-python25.patch, +fusil-1.4.ebuild:
+ Version bump
30 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
fusil-1.3.2.ebuild:
diff --git a/dev-python/fusil/files/1.4-python25.patch b/dev-python/fusil/files/1.4-python25.patch
new file mode 100644
index 000000000000..b36643b5c4a7
--- /dev/null
+++ b/dev-python/fusil/files/1.4-python25.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 712796e..40ea469 100755
+--- a/setup.py
++++ b/setup.py
+@@ -17,6 +17,7 @@
+ # - set version to n+1
+ # - add a new empty section in the changelog for version n+1
+
++from __future__ import with_statement
+ from imp import load_source
+ from os import path
+ from sys import argv
diff --git a/dev-python/fusil/fusil-1.4.ebuild b/dev-python/fusil/fusil-1.4.ebuild
new file mode 100644
index 000000000000..c34f34eaba9a
--- /dev/null
+++ b/dev-python/fusil/fusil-1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.4.ebuild,v 1.1 2011/07/29 22:28:05 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils eutils
+
+DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs."
+HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home http://pypi.python.org/pypi/fusil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-python/python-ptrace-0.6"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-python25.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd doc
+ emake RST2HTML="rst2html.py" || die "Generation of documentation failed"
+ fi
+}
+
+src_install(){
+ distutils_src_install
+ if use doc; then
+ dohtml doc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ enewgroup fusil
+ enewuser fusil -1 -1 -1 "fusil"
+}