summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-23 16:01:36 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-23 16:01:36 +0000
commit7fce5ad44baefcbe838c25f5c34c4e5f96ba42ec (patch)
treec69858e708c3324923aeccd237a46e36d5051c82 /dev-tcltk
parentInitial commit. (diff)
downloadgentoo-2-7fce5ad44baefcbe838c25f5c34c4e5f96ba42ec.tar.gz
gentoo-2-7fce5ad44baefcbe838c25f5c34c4e5f96ba42ec.tar.bz2
gentoo-2-7fce5ad44baefcbe838c25f5c34c4e5f96ba42ec.zip
touchups
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/expect-5.33.0.ebuild31
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r1.ebuild11
-rw-r--r--dev-tcltk/expect/expect-5.37.1.ebuild30
3 files changed, 26 insertions, 46 deletions
diff --git a/dev-tcltk/expect/expect-5.33.0.ebuild b/dev-tcltk/expect/expect-5.33.0.ebuild
index b7b5da3fdae7..6ff350b6e18b 100644
--- a/dev-tcltk/expect/expect-5.33.0.ebuild
+++ b/dev-tcltk/expect/expect-5.33.0.ebuild
@@ -1,33 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.33.0.ebuild,v 1.10 2003/03/14 08:23:54 george Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.33.0.ebuild,v 1.11 2003/04/23 16:01:36 vapier Exp $
#remove the trailing ".0" from the tarball version
S=${WORKDIR}/${P%.0}
-DESCRIPTION="Expect is a tool for automating interactive applications"
-
+DESCRIPTION="tool for automating interactive applications"
SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
HOMEPAGE="http://expect.nist.gov/"
-#tcl and tk really need to be broken out into their own ebuilds,
-#makes it hard to do conditional X? depends
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
-
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc alpha"
+IUSE="X"
-src_compile() {
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+src_compile() {
local myconf
local tclv
local tkv
+
# Find the version of tcl/tk that has headers installed.
# This will be the most recently merged, not necessarily the highest
# version number.
@@ -38,23 +32,20 @@ src_compile() {
#configure needs to find the files tclConfig.sh and tclInt.h
myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
- if use X; then
+ if [ `use X` ]; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
+ myconf="${myconf} --with-tk=/usr/lib"
else
#configure knows that tk depends on X so just disable X
myconf="$myconf --without-x"
fi
- econf $myconf || die
+ econf ${myconf} || die
emake || die
-
}
-src_install () {
-
+src_install() {
einstall || die
-
}
diff --git a/dev-tcltk/expect/expect-5.37.1-r1.ebuild b/dev-tcltk/expect/expect-5.37.1-r1.ebuild
index 39206a1675ee..b3dc194765e0 100644
--- a/dev-tcltk/expect/expect-5.37.1-r1.ebuild
+++ b/dev-tcltk/expect/expect-5.37.1-r1.ebuild
@@ -1,26 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r1.ebuild,v 1.10 2003/03/10 22:28:57 agriffis Exp $
-
-IUSE="X doc"
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r1.ebuild,v 1.11 2003/04/23 16:01:36 vapier Exp $
#remove the trailing ".0" from the tarball version
S=${WORKDIR}/${P%.1}
-DESCRIPTION="Expect is a tool for automating interactive applications"
+DESCRIPTION="tool for automating interactive applications"
SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
HOMEPAGE="http://expect.nist.gov/"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
LICENSE="BSD"
+IUSE="X doc"
DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
+ X? ( >=dev-lang/tk-8.2 )"
src_compile() {
-
local myconf
local tclv
local tkv
diff --git a/dev-tcltk/expect/expect-5.37.1.ebuild b/dev-tcltk/expect/expect-5.37.1.ebuild
index cf60fd995b99..b379bf5a0dc3 100644
--- a/dev-tcltk/expect/expect-5.37.1.ebuild
+++ b/dev-tcltk/expect/expect-5.37.1.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1.ebuild,v 1.7 2003/02/13 11:45:45 vapier Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1.ebuild,v 1.8 2003/04/23 16:01:36 vapier Exp $
#remove the trailing ".0" from the tarball version
S=${WORKDIR}/${P%.1}
-DESCRIPTION="Expect is a tool for automating interactive applications"
+DESCRIPTION="tool for automating interactive applications"
SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
HOMEPAGE="http://expect.nist.gov/"
SLOT="0"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
LICENSE="BSD"
+IUSE="X"
DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
+ X? ( >=dev-lang/tk-8.2 )"
src_compile() {
-
local myconf
local tclv
local tkv
+
# Find the version of tcl/tk that has headers installed.
# This will be the most recently merged, not necessarily the highest
# version number.
@@ -34,27 +32,21 @@ src_compile() {
#configure needs to find the files tclConfig.sh and tclInt.h
myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
- if use X; then
+ if [ `use X` ]; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
+ myconf="${myconf} --with-tk=/usr/lib"
else
#configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
+ myconf="${myconf} --without-x"
fi
- econf $myconf || die
+ econf ${myconf} || die
emake || die
-
}
-src_install () {
-
+src_install() {
einstall || die
-
- #docs
dodoc Changelog FAQ HISTORY NEWS README
-
}
-