summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Glover <jmglov@gentoo.org>2008-05-04 03:22:38 +0000
committerJosh Glover <jmglov@gentoo.org>2008-05-04 03:22:38 +0000
commit38cacda74553cd59bde0c137cc565e4d7fb28368 (patch)
treea167546746cd1e8d8ae877ba7de882fd90f5eea2 /dev-util/cunit
parentinitial revision of app-editors/xemacs-21.5.28 (diff)
downloadgentoo-2-38cacda74553cd59bde0c137cc565e4d7fb28368.tar.gz
gentoo-2-38cacda74553cd59bde0c137cc565e4d7fb28368.tar.bz2
gentoo-2-38cacda74553cd59bde0c137cc565e4d7fb28368.zip
Version bump; submitted by Hal Ashburner in bug #214465
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/cunit')
-rw-r--r--dev-util/cunit/ChangeLog9
-rw-r--r--dev-util/cunit/cunit-2.1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-util/cunit/ChangeLog b/dev-util/cunit/ChangeLog
index 94d02290d1af..06ad7b0779a4 100644
--- a/dev-util/cunit/ChangeLog
+++ b/dev-util/cunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cunit
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.17 2007/08/13 20:46:58 dertobi123 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.18 2008/05/04 03:22:38 jmglov Exp $
+
+*cunit-2.1 (06 Apr 2008)
+
+ 06 Apr 2008; Josh Glover <jmglov@gentoo.org> +cunit-2.1.ebuild:
+ This package was submitted by Hal Ashburner in bug #214465
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org> cunit-2.0.ebuild:
ppc. stable
diff --git a/dev-util/cunit/cunit-2.1.ebuild b/dev-util/cunit/cunit-2.1.ebuild
new file mode 100644
index 000000000000..2424312c10da
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1.ebuild,v 1.1 2008/05/04 03:22:38 jmglov Exp $
+
+inherit eutils autotools
+
+MY_PN='CUnit'
+MY_PV="${PV}-0"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.gz"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+DEPEND="virtual/libc"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ eautoreconf
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}