summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-04-09 08:05:49 +0000
committerPacho Ramos <pacho@gentoo.org>2010-04-09 08:05:49 +0000
commitf97ba5f983d816fa274886375e51f08c8bb0d8dc (patch)
treebb367d2e767aecf8bf9558138497141460f622d7 /dev-util/gob
parentCleanup (diff)
downloadgentoo-2-f97ba5f983d816fa274886375e51f08c8bb0d8dc.tar.gz
gentoo-2-f97ba5f983d816fa274886375e51f08c8bb0d8dc.tar.bz2
gentoo-2-f97ba5f983d816fa274886375e51f08c8bb0d8dc.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/gob')
-rw-r--r--dev-util/gob/ChangeLog10
-rw-r--r--dev-util/gob/gob-2.0.17.ebuild28
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-util/gob/ChangeLog b/dev-util/gob/ChangeLog
index 8122902cec5c..a162fc972bd7 100644
--- a/dev-util/gob/ChangeLog
+++ b/dev-util/gob/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/gob
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/ChangeLog,v 1.70 2010/01/15 21:40:42 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/ChangeLog,v 1.71 2010/04/09 08:05:49 pacho Exp $
+
+*gob-2.0.17 (09 Apr 2010)
+
+ 09 Apr 2010; Pacho Ramos <pacho@gentoo.org> +gob-2.0.17.ebuild:
+ Version bump: fix segfault when defining the finilize, dispose, and
+ constructor methods; handle carriage returns in input files; use
+ -G_MAXFLOAT and -G_MAXDOUBLE for the default minima for floating point
+ numbers.
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org> gob-2.0.16.ebuild:
Transfer Prefix keywords
diff --git a/dev-util/gob/gob-2.0.17.ebuild b/dev-util/gob/gob-2.0.17.ebuild
new file mode 100644
index 000000000000..0eb0e2e3d336
--- /dev/null
+++ b/dev-util/gob/gob-2.0.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-2.0.17.ebuild,v 1.1 2010/04/09 08:05:49 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+MY_PN=gob2
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Preprocessor for making GTK+ objects with inline C code"
+HOMEPAGE="http://www.5z.com/jirka/gob.html"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"