summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-07-27 10:38:48 +0000
committerFabian Groffen <grobian@gentoo.org>2014-07-27 10:38:48 +0000
commit015c1912da5f6f9cc0d2e27d2dbad5efee52fc40 (patch)
tree2b0a9f0483a44f2bc5d67f872d7cc614018bf94d /dev-vcs/git/git-9999-r1.ebuild
parentx86 stable wrt bug #517200 (diff)
downloadgentoo-2-015c1912da5f6f9cc0d2e27d2dbad5efee52fc40.tar.gz
gentoo-2-015c1912da5f6f9cc0d2e27d2dbad5efee52fc40.tar.bz2
gentoo-2-015c1912da5f6f9cc0d2e27d2dbad5efee52fc40.zip
Fix compilation with USE=subversion on platforms without intl and iconv in libc, bug #516168, force for odd syntax errors in dependencies in untouched ebuilds that Portage otherwise is fine with
(Portage version: 2.2.10.1-prefix/cvs/Darwin i386, RepoMan options: --force, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-vcs/git/git-9999-r1.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index e9b68030975a..9b57293c0dd1 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.3 2014/06/24 01:44:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.4 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi