summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-20 15:14:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-20 15:14:56 +0000
commita9e57e0206cdb0ff5d1e02b1b82696ebe353a4f4 (patch)
treec5f0f0e42219952892cc657112f6f7592cf616df /games-puzzle/arrows/arrows-0.6.ebuild
parentOpenMP: Handle full specifier for gfortran correctly so that the default, uns... (diff)
downloadgentoo-2-a9e57e0206cdb0ff5d1e02b1b82696ebe353a4f4.tar.gz
gentoo-2-a9e57e0206cdb0ff5d1e02b1b82696ebe353a4f4.tar.bz2
gentoo-2-a9e57e0206cdb0ff5d1e02b1b82696ebe353a4f4.zip
EAPI=2; honor CC and LDFLAGS (bug #333607)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/arrows/arrows-0.6.ebuild')
-rw-r--r--games-puzzle/arrows/arrows-0.6.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/games-puzzle/arrows/arrows-0.6.ebuild b/games-puzzle/arrows/arrows-0.6.ebuild
index 65f2e330a6ff..c2685b0a359f 100644
--- a/games-puzzle/arrows/arrows-0.6.ebuild
+++ b/games-puzzle/arrows/arrows-0.6.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.8 2008/03/07 16:44:46 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/arrows/arrows-0.6.ebuild,v 1.9 2010/08/20 15:14:56 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="simple maze-like game where you navigate around and destroy arrows"
@@ -13,14 +14,11 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.4.0"
+RDEPEND=">=x11-libs/gtk+-2.4:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Modify path to data
sed -i \
-e "s:arrfl:${GAMES_DATADIR}/${PN}/arrfl:" \
@@ -28,7 +26,12 @@ src_unpack() {
-e 's:nm\[6:nm[30:' \
-e 's:nm\[7:nm[31:' \
game.c \
- || die "sed game.c failed"
+ || die 'sed failed'
+ sed -i \
+ -e '/^CC /d' \
+ -e '/CCLIBS/s:$: $(LDFLAGS):' \
+ Makefile \
+ || die 'sed failed'
}
src_compile() {