summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-05 05:38:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-05 05:38:33 +0000
commitee95985ec7a155c7945f67923e8cd12a2b8fbdca (patch)
tree6d8445978658f5714a73e972e05decaf9b18b73c /games-roguelike
parentStable on x86 (diff)
downloadgentoo-2-ee95985ec7a155c7945f67923e8cd12a2b8fbdca.tar.gz
gentoo-2-ee95985ec7a155c7945f67923e8cd12a2b8fbdca.tar.bz2
gentoo-2-ee95985ec7a155c7945f67923e8cd12a2b8fbdca.zip
turn off -O to prevent segfault in reponse to bug #113627
(Portage version: 2.0.53)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/ivan/ChangeLog7
-rw-r--r--games-roguelike/ivan/ivan-0.50.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/games-roguelike/ivan/ChangeLog b/games-roguelike/ivan/ChangeLog
index 3d0dd37a6160..c98f1b2193b4 100644
--- a/games-roguelike/ivan/ChangeLog
+++ b/games-roguelike/ivan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-roguelike/ivan
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.6 2005/11/27 02:01:11 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.7 2006/01/05 05:38:33 mr_bones_ Exp $
+
+ 05 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> ivan-0.50.ebuild:
+ turn off -O to prevent segfault in reponse to bug #113627
27 Nov 2005; Michael Sterrett <mr_bones_@gentoo.org> ivan-0.50.ebuild:
keepdir the Bones directory so it doesn't get accidentally removed
diff --git a/games-roguelike/ivan/ivan-0.50.ebuild b/games-roguelike/ivan/ivan-0.50.ebuild
index 1b71a0c1e870..9afafa061c90 100644
--- a/games-roguelike/ivan/ivan-0.50.ebuild
+++ b/games-roguelike/ivan/ivan-0.50.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.2 2005/11/27 02:01:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.3 2006/01/05 05:38:33 mr_bones_ Exp $
-inherit games
+inherit flag-o-matic games
DESCRIPTION="Rogue-like game with SDL graphics"
HOMEPAGE="http://ivan.sourceforge.net/"
@@ -15,6 +15,12 @@ IUSE=""
DEPEND=">=media-libs/libsdl-1.2.0"
+src_compile() {
+ replace-flags -O? -O0 #bug #113627
+ egamesconf || die
+ emake || die "emake failed"
+}
+
src_install() {
egamesinstall || die
dodoc AUTHORS ChangeLog LICENSING NEWS README