summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 17:26:39 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2011-05-08 17:26:39 +0000
commit3d946aae50fb4483e702dd9d55dd60cd1bb43315 (patch)
treed12117411edaa852d11088d2ec0eca40e2660e77 /kde-base/ark/files
parentsupport db-4.8 and db-4.7 as well (diff)
downloadgentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.tar.gz
gentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.tar.bz2
gentoo-2-3d946aae50fb4483e702dd9d55dd60cd1bb43315.zip
Added patch from upstream bug (https://bugs.kde.org/show_bug.cgi?id=271553).
Fixes bug 366311. (Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ark/files')
-rw-r--r--kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch25
-rw-r--r--kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch32
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch b/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
new file mode 100644
index 000000000000..452830f83a1c
--- /dev/null
+++ b/kde-base/ark/files/ark-4.4.5-detect-libarchive-in-proper-place.patch
@@ -0,0 +1,25 @@
+diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
+index 6ea72bb..85c5ce0 100644
+--- a/ark/CMakeLists.txt
++++ b/ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
+diff --git a/ark/plugins/CMakeLists.txt b/ark/plugins/CMakeLists.txt
+index a8c4e44..e3cb9ec 100644
+--- a/ark/plugins/CMakeLists.txt
++++ b/ark/plugins/CMakeLists.txt
+@@ -1,7 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://people.freebsd.org/~kientzle/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark. Make sure it is compiled with gzip support.")
+-
+ if (LIBARCHIVE_FOUND)
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+ message(STATUS "Your libarchive does not have support for lzma and/or xz archives. libarchive >= 2.7.0 is recommended.")
diff --git a/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch b/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch
new file mode 100644
index 000000000000..0a7bd5085820
--- /dev/null
+++ b/kde-base/ark/files/ark-detect-libarchive-in-proper-place.patch
@@ -0,0 +1,32 @@
+diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
+index 6ea72bb..85c5ce0 100644
+--- a/ark/CMakeLists.txt
++++ b/ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
+diff --git a/ark/plugins/CMakeLists.txt b/ark/plugins/CMakeLists.txt
+index a8c4e44..e3cb9ec 100644
+--- a/ark/plugins/CMakeLists.txt
++++ b/ark/plugins/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+ if (LIBARCHIVE_FOUND)
+ if( HAVE_LIBARCHIVE_READ_DISK_API )
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+@@ -15,8 +13,6 @@ if (LIBARCHIVE_FOUND)
+ endif( HAVE_LIBARCHIVE_READ_DISK_API )
+ endif (LIBARCHIVE_FOUND)
+
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
+-
+ add_subdirectory( clirarplugin )
+ add_subdirectory( cli7zplugin )
+ add_subdirectory( clizipplugin )