summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-08-21 11:56:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-08-21 11:56:52 +0000
commit9d0fbbf0c82e7aad63af126f4a2eabd5cce820a7 (patch)
tree27ae1b2e9b32cd9cb3a2b03a68684cd9948f55a8 /media-libs/jpeg/jpeg-8d-r2.ebuild
parentsys-fs/aufs3: Bump to latest aufs3 (diff)
downloadgentoo-2-9d0fbbf0c82e7aad63af126f4a2eabd5cce820a7.tar.gz
gentoo-2-9d0fbbf0c82e7aad63af126f4a2eabd5cce820a7.tar.bz2
gentoo-2-9d0fbbf0c82e7aad63af126f4a2eabd5cce820a7.zip
Special SLOT="8" to install only libjpeg.so.8 SONAME
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/jpeg/jpeg-8d-r2.ebuild')
-rw-r--r--media-libs/jpeg/jpeg-8d-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/jpeg/jpeg-8d-r2.ebuild b/media-libs/jpeg/jpeg-8d-r2.ebuild
new file mode 100644
index 000000000000..82f9b84a413e
--- /dev/null
+++ b/media-libs/jpeg/jpeg-8d-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-8d-r2.ebuild,v 1.1 2014/08/21 11:56:52 ssuominen Exp $
+
+EAPI=5
+
+# this ebuild is only for the libjpeg.so.8 SONAME for ABI compat
+
+inherit eutils libtool toolchain-funcs multilib-minimal
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz"
+
+LICENSE="IJG"
+SLOT="8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!=media-libs/jpeg-8*:0
+ !<media-libs/libjpeg-turbo-1.3.0-r2
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+DOCS=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch \
+ "${FILESDIR}"/${P}-CVE-2013-6629.patch
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # Fix building against this library on eg. Solaris and DragonFly BSD, see:
+ # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
+ local ldverscript=
+ [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --enable-maxmem=64 \
+ ${ldverscript}
+}
+
+multilib_src_compile() {
+ emake libjpeg.la
+}
+
+multilib_src_install() {
+ newlib.so .libs/libjpeg.so.8.4.0 libjpeg.so.8
+}