summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-04-02 15:43:38 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-04-02 15:43:38 +0000
commit02d2361fbde1241fa6da355c3c94edecfb40db18 (patch)
tree22213344c274c6226f00d03ef17658816c3f152c /media-sound/cymbaline/cymbaline-0.9r.ebuild
parentnew package, closes bug 660 (diff)
downloadgentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.tar.gz
gentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.tar.bz2
gentoo-2-02d2361fbde1241fa6da355c3c94edecfb40db18.zip
initial import, closes bug 676
Diffstat (limited to 'media-sound/cymbaline/cymbaline-0.9r.ebuild')
-rw-r--r--media-sound/cymbaline/cymbaline-0.9r.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/cymbaline/cymbaline-0.9r.ebuild b/media-sound/cymbaline/cymbaline-0.9r.ebuild
new file mode 100644
index 000000000000..8884bdf41ec0
--- /dev/null
+++ b/media-sound/cymbaline/cymbaline-0.9r.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cymbaline/cymbaline-0.9r.ebuild,v 1.1 2003/04/02 15:43:38 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="Smart Command Line Mp3 Player"
+SRC_URI="http://www.silmarill.org/files/${P}.tar.gz"
+HOMEPAGE="http://silmarill.org/cymbaline.htm"
+IUSE="mikmod oggvorbis"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+RESTRICT="nostrip"
+
+DEPEND="dev-lang/python
+ media-sound/mpg123
+ media-sound/aumix
+ mikmod? ( media-sound/mikmod )
+ oggvorbis? ( media-sound/vorbis-tools ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ einfo No compilation necessary.
+}
+
+src_install () {
+ dodir /usr/lib/cymbaline
+ exeinto /usr/bin
+ newexe cymbaline.py cymbaline
+ insinto /usr/lib/cymbaline
+ doins ID3.py mp3.py cycolors.py
+}
+