summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-29 21:45:09 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-29 21:45:09 +0000
commitcdc67ceb080dc5e9ed23212f4f2fde0e23978171 (patch)
tree49bdc0df7608b046c78300eebe870769e9293838 /media-sound/freeamp
parentbig commit :-) read gentoo-announce msg and eclass/doc/news.txt for details (diff)
downloadgentoo-2-cdc67ceb080dc5e9ed23212f4f2fde0e23978171.tar.gz
gentoo-2-cdc67ceb080dc5e9ed23212f4f2fde0e23978171.tar.bz2
gentoo-2-cdc67ceb080dc5e9ed23212f4f2fde0e23978171.zip
more fixes and updates. expect all the rest, plus app-doc/qt-docs (and 3.0.1 qt and
qt-docs) ebuilds tomorrow evening IST.
Diffstat (limited to 'media-sound/freeamp')
-rw-r--r--media-sound/freeamp/files/digest-freeamp-2.1.11
-rw-r--r--media-sound/freeamp/freeamp-2.1.0.ebuild3
-rw-r--r--media-sound/freeamp/freeamp-2.1.1.ebuild52
3 files changed, 55 insertions, 1 deletions
diff --git a/media-sound/freeamp/files/digest-freeamp-2.1.1 b/media-sound/freeamp/files/digest-freeamp-2.1.1
new file mode 100644
index 000000000000..2f578304d5ad
--- /dev/null
+++ b/media-sound/freeamp/files/digest-freeamp-2.1.1
@@ -0,0 +1 @@
+MD5 56720f823f84c3505aeab474c9a6a836 freeamp-2.1.1.tar.bz2 3125248
diff --git a/media-sound/freeamp/freeamp-2.1.0.ebuild b/media-sound/freeamp/freeamp-2.1.0.ebuild
index d5fb0c770ac7..bf1a4098c098 100644
--- a/media-sound/freeamp/freeamp-2.1.0.ebuild
+++ b/media-sound/freeamp/freeamp-2.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.0.ebuild,v 1.1 2001/10/12 18:43:25 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.0.ebuild,v 1.2 2001/12/29 21:45:08 danarmak Exp $
# I highly suggest you read the features section of the freeamp website to
# see all the neat stuff this program can do. Pretty spiffy :)
@@ -31,6 +31,7 @@ src_compile() {
local myconf
use alsa || myconf="${myconf} --disable-alsa"
use esd || myconf="${myconf} --disable-esd"
+ use arts && export KDEDIR=/usr/kde/2
./configure --prefix=/usr --host=${CHOST} ${myconf} || die
make ; assert "compile problem :("
diff --git a/media-sound/freeamp/freeamp-2.1.1.ebuild b/media-sound/freeamp/freeamp-2.1.1.ebuild
new file mode 100644
index 000000000000..34ac53e78baf
--- /dev/null
+++ b/media-sound/freeamp/freeamp-2.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freeamp/freeamp-2.1.1.ebuild,v 1.1 2001/12/29 21:45:08 danarmak Exp $
+
+# I highly suggest you read the features section of the freeamp website to
+# see all the neat stuff this program can do. Pretty spiffy :)
+
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support"
+SRC_URI="http://www.freeamp.org/download/src/${P}.tar.bz2"
+HOMEPAGE="http://www.freeamp.org/"
+S=${WORKDIR}/freeamp
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.5 >=x11-libs/gtk+-1.2.5
+ >=sys-libs/zlib-1.1.3 >=sys-libs/ncurses-5.2
+ ~media-libs/freetype-1.3.1 >=media-libs/musicbrainz-1.0.1
+ esd? ( media-sound/esound ) alsa? ( media-libs/alsa-lib )
+ gnome? ( gnome-base/ORBit >=media-libs/gdk-pixbuf-0.8 )
+ X? ( virtual/x11 ) arts? ( kde-base/kdelibs )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND} dev-lang/nasm sys-devel/perl"
+
+# Unfortunately you can't selectively build a lot of the features. Therefore
+# this whole package is essentially a judgement call. However, I've made the
+# DEPEND in a strategic manner to ensure that your USE variable is respected
+# when the knobs are *set*.
+
+src_compile() {
+
+ local myconf
+ use alsa || myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+ use arts && export KDEDIR=/usr/kde/2
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ make ; assert "compile problem :("
+}
+
+src_install() {
+
+ into /usr ; dobin freeamp
+ exeinto /usr/lib/freeamp/plugins ; doexe plugins/*
+ insinto /usr/share/freeamp/themes ; doins themes/*
+ dodir /usr/share/freeamp/fonts
+
+ dodoc AUTHORS ChangeLog CHANGES COPYING NEWS README README.linux
+
+ cd ${D}/usr/share/freeamp ; tar zxf ${S}/help/unix/freeamphelp.tar.gz
+ chown -R root.root help ; chmod 644 help/*
+ dosym /usr/share/freeamp/help /usr/share/doc/${PF}/html
+}