summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-24 13:26:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-24 13:26:29 +0000
commit3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2 (patch)
tree257257f75ac5ec21728d774df7f890f8606714f4 /media-video/x264-encoder/files
parentbump a new snapshot (diff)
downloadgentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.tar.gz
gentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.tar.bz2
gentoo-2-3ba55a105dc6a5aa85dc3ca495ec93f06376d8c2.zip
bump a new snapshot
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'media-video/x264-encoder/files')
-rw-r--r--media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch b/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch
new file mode 100644
index 000000000000..b7838c6e5fcd
--- /dev/null
+++ b/media-video/x264-encoder/files/x264-encoder-nolib-20110223.patch
@@ -0,0 +1,38 @@
+Index: x264-snapshot-20110223-2245/Makefile
+===================================================================
+--- x264-snapshot-20110223-2245.orig/Makefile
++++ x264-snapshot-20110223-2245/Makefile
+@@ -146,8 +146,8 @@ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
+ $(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
+
+-x264$(EXE): $(OBJCLI) libx264.a
+- $(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS)
++x264$(EXE): $(OBJCLI)
++ $(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS) `pkg-config --libs x264`
+
+ checkasm: tools/checkasm.o libx264.a
+ $(CC) -o $@ $+ $(LDFLAGS)
+@@ -214,22 +214,7 @@ distclean: clean
+
+ install: x264$(EXE) $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+- install -d $(DESTDIR)$(includedir)
+- install -d $(DESTDIR)$(libdir)
+- install -d $(DESTDIR)$(libdir)/pkgconfig
+- install -m 644 x264.h $(DESTDIR)$(includedir)
+- install -m 644 x264_config.h $(DESTDIR)$(includedir)
+- install -m 644 libx264.a $(DESTDIR)$(libdir)
+- install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+ install x264$(EXE) $(DESTDIR)$(bindir)
+- $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+-ifeq ($(SYS),MINGW)
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
+-else
+- $(if $(SONAME), ln -f -s $(SONAME) $(DESTDIR)$(libdir)/libx264.$(SOSUFFIX))
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(libdir))
+-endif
+- $(if $(IMPLIBNAME), install -m 644 $(IMPLIBNAME) $(DESTDIR)$(libdir))
+
+ uninstall:
+ rm -f $(DESTDIR)$(includedir)/x264.h $(DESTDIR)$(includedir)/x264_config.h $(DESTDIR)$(libdir)/libx264.a