summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-10-09 17:29:41 +0000
committerHanno Böck <hanno@gentoo.org>2011-10-09 17:29:41 +0000
commite1524be8f4152e8c03aeba4bd331736c51411fb9 (patch)
treeffa3cdd20cbaa7cc93831fc54c65a25c3eab2443 /net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
parentppc stable wrt #380525 (diff)
downloadgentoo-2-e1524be8f4152e8c03aeba4bd331736c51411fb9.tar.gz
gentoo-2-e1524be8f4152e8c03aeba4bd331736c51411fb9.tar.bz2
gentoo-2-e1524be8f4152e8c03aeba4bd331736c51411fb9.zip
Initial commit of greenbone-security-assistant, part of openvas 4.
(Portage version: 2.1.10.24/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild')
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
new file mode 100644
index 000000000000..65d2fd748de6
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild,v 1.1 2011/10/09 17:29:41 hanno Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/857/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-4
+ dev-libs/libxslt
+ net-libs/libmicrohttpd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/cmake"
+
+# Workaround for upstream bug, it doesn't like out-of-tree builds.
+CMAKE_BUILD_DIR="${S}"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README || die "dodoc failed"
+ doinitd "${FILESDIR}"/gsad || die
+}