summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjolnir@gentoo.org>2007-07-28 16:51:51 +0000
committerMartin Jackson <mjolnir@gentoo.org>2007-07-28 16:51:51 +0000
commit91b2c9ed139fd196eb074fcc119cc1289cfff416 (patch)
treef6ab7295bf2c5a9d90b98d4bedd56351c6d0763b /net-analyzer/snmptt/snmptt-1.2.ebuild
parentVersion bump thanks to Jose daLuz in bug #177571 (diff)
downloadgentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.tar.gz
gentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.tar.bz2
gentoo-2-91b2c9ed139fd196eb074fcc119cc1289cfff416.zip
Bump to 1.2 for #184764
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-analyzer/snmptt/snmptt-1.2.ebuild')
-rw-r--r--net-analyzer/snmptt/snmptt-1.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/snmptt/snmptt-1.2.ebuild b/net-analyzer/snmptt/snmptt-1.2.ebuild
new file mode 100644
index 000000000000..b308fde4bd18
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/snmptt-1.2.ebuild,v 1.1 2007/07/28 16:51:51 mjolnir Exp $
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~ppc ~sparc ~x86"
+SLOT="0"
+IUSE="mysql postgres"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/Config-IniFiles
+ >=net-analyzer/net-snmp-5.1
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 105354, daemonize this thing
+ sed -i -e "s:mode = standalone:mode = daemon:g" snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
+}
+
+src_install() {
+ into /usr
+ dosbin snmptt
+ dosbin snmptthandler
+ dosbin snmptt-net-snmp-test
+ dosbin snmpttconvert
+ dosbin snmpttconvertmib
+
+ insinto /etc/snmp
+ doins snmptt.ini
+ doins examples/snmptt.conf.generic
+ cp -pPR ${D}/etc/snmp/snmptt.conf.generic ${D}/etc/snmp/snmptt.conf
+ doins examples/snmptrapd.conf.sample
+
+ dodoc BUGS ChangeLog README sample-trap
+ dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html docs/snmpttconvert.html docs/snmpttconvertmib.html
+
+ newinitd "${FILESDIR}"/snmptt.initd snmptt
+}
+
+pkg_postinst() {
+ if ( use mysql || use postgres ); then
+ elog "Read the html documentation to configure your database."
+ fi
+ elog "Please configure /etc/snmp/snmptt.conf before running."
+}