summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-09-17 14:50:45 +0000
committerMarinus Schraal <foser@gentoo.org>2006-09-17 14:50:45 +0000
commit06cfb47813130a76be709a85cd22c72a862b3388 (patch)
tree21eb9fc2d9cdbb9987aa6a1965a6d6b54dc44b6b /net-libs/loudmouth/loudmouth-1.0.5.ebuild
parentNew release (diff)
downloadgentoo-2-06cfb47813130a76be709a85cd22c72a862b3388.tar.gz
gentoo-2-06cfb47813130a76be709a85cd22c72a862b3388.tar.bz2
gentoo-2-06cfb47813130a76be709a85cd22c72a862b3388.zip
new release
(Portage version: 2.1)
Diffstat (limited to 'net-libs/loudmouth/loudmouth-1.0.5.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-1.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-1.0.5.ebuild b/net-libs/loudmouth/loudmouth-1.0.5.ebuild
new file mode 100644
index 000000000000..b6e472819da0
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.0.5.ebuild,v 1.1 2006/09/17 14:50:45 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://loudmouth.imendio.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc ssl debug"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+
+ G2CONF="$(use_with ssl) \
+ $(use_enable debug)\
+ $(use_enable doc gtk-doc)"
+
+}