summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-02-21 07:25:04 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-02-21 07:25:04 +0000
commit5478af01357f07cca8eeee4496a320148926b51b (patch)
treea4dd0ed1bfe48fe9d2c08dae1ae720388dca2933 /net-libs
parent[bump] dev-perl/Mouse-0.900 (diff)
downloadgentoo-2-5478af01357f07cca8eeee4496a320148926b51b.tar.gz
gentoo-2-5478af01357f07cca8eeee4496a320148926b51b.tar.bz2
gentoo-2-5478af01357f07cca8eeee4496a320148926b51b.zip
Bump to 0.1.0, EAPI is now 3, passes all tests
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnice/ChangeLog7
-rw-r--r--net-libs/libnice/libnice-0.1.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/libnice/ChangeLog b/net-libs/libnice/ChangeLog
index 680ad07526c1..a8f032b6c08a 100644
--- a/net-libs/libnice/ChangeLog
+++ b/net-libs/libnice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.19 2011/02/13 11:31:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/ChangeLog,v 1.20 2011/02/21 07:25:04 nirbheek Exp $
+
+*libnice-0.1.0 (21 Feb 2011)
+
+ 21 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +libnice-0.1.0.ebuild:
+ Bump to 0.1.0, EAPI is now 3, passes all tests
13 Feb 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Add gnome to metadata as talked between us since empathy relies on this.
diff --git a/net-libs/libnice/libnice-0.1.0.ebuild b/net-libs/libnice/libnice-0.1.0.ebuild
new file mode 100644
index 000000000000..c2940e3309a9
--- /dev/null
+++ b/net-libs/libnice/libnice-0.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnice/libnice-0.1.0.ebuild,v 1.1 2011/02/21 07:25:04 nirbheek Exp $
+
+EAPI="3"
+
+inherit eutils libtool
+
+DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+SRC_URI="http://nice.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+gstreamer upnp"
+
+RDEPEND=">=dev-libs/glib-2.10
+ gstreamer? (
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10 )
+ upnp? ( >=net-libs/gupnp-igd-0.1.3 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.0.13-darwin.patch
+ elibtoolize # for .bundle on Darwin
+}
+
+src_configure() {
+ econf --disable-static \
+ $(use_with gstreamer) \
+ $(use_enable upnp gupnp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS COPYING* README NEWS || die "dodoc failed."
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}