summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-06-23 09:53:44 +0000
committerChristoph Mende <angelos@gentoo.org>2010-06-23 09:53:44 +0000
commit6ab7dd495c7d8fdc649eb716273c461a4a32727c (patch)
tree2dae2a301ffe1e718a0eada805b3b86ead87ce2e /net-misc/corkscrew/corkscrew-2.0.ebuild
parentversion bump and clean up (diff)
downloadgentoo-2-6ab7dd495c7d8fdc649eb716273c461a4a32727c.tar.gz
gentoo-2-6ab7dd495c7d8fdc649eb716273c461a4a32727c.tar.bz2
gentoo-2-6ab7dd495c7d8fdc649eb716273c461a4a32727c.zip
Regenerate autotools to fix bug #305771, also stable on amd64 wrt bug #284604
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/corkscrew/corkscrew-2.0.ebuild')
-rw-r--r--net-misc/corkscrew/corkscrew-2.0.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/net-misc/corkscrew/corkscrew-2.0.ebuild b/net-misc/corkscrew/corkscrew-2.0.ebuild
index 24f2654ab58e..e17f5dcaffb7 100644
--- a/net-misc/corkscrew/corkscrew-2.0.ebuild
+++ b/net-misc/corkscrew/corkscrew-2.0.ebuild
@@ -1,24 +1,31 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/corkscrew-2.0.ebuild,v 1.9 2010/06/22 17:41:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/corkscrew/corkscrew-2.0.ebuild,v 1.10 2010/06/23 09:53:44 angelos Exp $
-EAPI=2
-inherit toolchain-funcs
+EAPI=3
+inherit autotools
-DESCRIPTION="Corkscrew is a tool for tunneling SSH through HTTP proxies."
+DESCRIPTION="a tool for tunneling SSH through HTTP proxies."
HOMEPAGE="http://www.agroman.net/corkscrew/"
+SRC_URI="http://www.agroman.net/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
-DEPEND=""
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
SLOT="0"
-SRC_URI="http://www.agroman.net/corkscrew/${P}.tar.gz"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
-src_compile() {
- emake CC=$(tc-getCC) || die "emake failed"
+src_prepare() {
+ # Christoph Mende <angelos@gentoo.org (23 Jun 2010)
+ # Shipped configure doesn't work with some locales (bug #305771)
+ # Shipped missing doesn't work with new configure, so we'll force
+ # regeneration
+ rm -f install-sh missing mkinstalldirs || die
+ eautoreconf
}
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
}