summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-12 05:16:13 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-12 05:16:13 +0000
commit008454e5738b3c1909b1dd1cd00cc68bd8949981 (patch)
treed8c6298c8f3a8cd0b55f9e763446956209609320 /sci-libs/qrupdate/qrupdate-1.1.0.ebuild
parentNew revision with dropped qt3 support (fixes bug #299190). (diff)
downloadgentoo-2-008454e5738b3c1909b1dd1cd00cc68bd8949981.tar.gz
gentoo-2-008454e5738b3c1909b1dd1cd00cc68bd8949981.tar.bz2
gentoo-2-008454e5738b3c1909b1dd1cd00cc68bd8949981.zip
Version bump.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/qrupdate/qrupdate-1.1.0.ebuild')
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/qrupdate/qrupdate-1.1.0.ebuild b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
new file mode 100644
index 000000000000..e6c1b69f303b
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0.ebuild,v 1.1 2010/01/12 05:16:13 markusle Exp $
+
+EAPI="2"
+
+inherit eutils fortran
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-makefile.patch
+
+ local BLAS_LIBS="$(pkg-config --libs blas)"
+ local LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ sed -i Makeconf \
+ -e "s:gfortran:${FORTRANC}:g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=${BLAS_LIBS}:" \
+ -e "s:LAPACK=.*:LAPACK=${LAPACK_LIBS}:" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake failed"
+}
+
+src_install() {
+ dolib.so libqrupdate.so \
+ || die "Failed to install libqrupdate.so"
+
+ dodoc README ChangeLog || die "dodoc failed"
+}