summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-24 06:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-24 06:07:47 +0000
commit51fec676a54782644c143bab7f7a39bd756a612e (patch)
tree19a9946bf48e6614ba73fa95d22c3c1ee2aaa70e /sys-apps/iproute2/files
parentfix building with USE=-ssl #137796 (diff)
downloadgentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.tar.gz
gentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.tar.bz2
gentoo-2-51fec676a54782644c143bab7f7a39bd756a612e.zip
Let portage strip binaries #137574 by Tristan Heaven.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-apps/iproute2/files')
-rw-r--r--sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch
new file mode 100644
index 000000000000..7512cfcc6b55
--- /dev/null
+++ b/sys-apps/iproute2/files/iproute2-2.6.16.20060323-build.patch
@@ -0,0 +1,41 @@
+let portage strip the binaries
+
+http://bugs.gentoo.org/137574
+
+--- ip/Makefile
++++ ip/Makefile
+@@ -16,7 +16,7 @@
+ rtmon: $(RTMONOBJ) $(LIBNETLINK)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ install -m 0755 $(SCRIPTS) $(DESTDIR)$(SBINDIR)
+
+ clean:
+
+--- misc/Makefile
++++ misc/Makefile
+@@ -27,7 +27,7 @@
+ lnstat: $(LNSTATOBJ)
+
+ install: all
+- install -m 0755 -s $(TARGETS) $(DESTDIR)$(SBINDIR)
++ install -m 0755 $(TARGETS) $(DESTDIR)$(SBINDIR)
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/rtstat
+ ln -sf lnstat $(DESTDIR)$(SBINDIR)/ctstat
+
+--- tc/Makefile
++++ tc/Makefile
+@@ -70,9 +70,9 @@
+
+ install: all
+ mkdir -p $(DESTDIR)/usr/lib/tc
+- install -m 0755 -s tc $(DESTDIR)$(SBINDIR)
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
+- do install -m 755 -s $$i $(DESTDIR)/usr/lib/tc; \
++ do install -m 755 $$i $(DESTDIR)/usr/lib/tc; \
+ done
+
+ clean: