summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-07 05:18:20 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-07 05:18:20 +0000
commit984f04ee418a1a0bf26d65c99d256b625bfab157 (patch)
tree368ae86ed63c9113e7a5f853f5f32cc2d8518e3f /sys-apps/util-linux
parentOld. (diff)
downloadgentoo-2-984f04ee418a1a0bf26d65c99d256b625bfab157.tar.gz
gentoo-2-984f04ee418a1a0bf26d65c99d256b625bfab157.tar.bz2
gentoo-2-984f04ee418a1a0bf26d65c99d256b625bfab157.zip
Add USE=ncurses to control the lib usage #221941 by Jim Kukunas and Mart Raudsepp.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/util-linux-2.19.ebuild9
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild9
3 files changed, 16 insertions, 9 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index f2f783077f84..0fde06274320 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.334 2011/04/07 01:09:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.335 2011/04/07 05:18:20 vapier Exp $
+
+ 07 Apr 2011; Mike Frysinger <vapier@gentoo.org> util-linux-2.19.ebuild,
+ util-linux-9999.ebuild:
+ Add USE=ncurses to control the lib usage #221941 by Jim Kukunas and Mart
+ Raudsepp.
07 Apr 2011; Mike Frysinger <vapier@gentoo.org> util-linux-2.19.ebuild,
+files/util-linux-2.19-old-libc.patch:
diff --git a/sys-apps/util-linux/util-linux-2.19.ebuild b/sys-apps/util-linux/util-linux-2.19.ebuild
index 19cd55bd5d1f..63670a45502b 100644
--- a/sys-apps/util-linux/util-linux-2.19.ebuild
+++ b/sys-apps/util-linux/util-linux-2.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.3 2011/04/07 01:09:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.4 2011/04/07 05:18:20 vapier Exp $
EAPI="2"
@@ -24,14 +24,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+cramfs crypt nls old-linux perl selinux slang uclibc unicode"
+IUSE="+cramfs crypt ncurses nls old-linux perl selinux slang uclibc unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
cramfs? ( sys-libs/zlib )
+ ncurses? ( >=sys-libs/ncurses-5.2-r2 )
perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
slang? ( sys-libs/slang )"
@@ -62,6 +62,7 @@ lfs_fallocate_test() {
rm -f "${T}"/fallocate.c
}
+usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
src_configure() {
lfs_fallocate_test
econf \
@@ -70,6 +71,7 @@ src_configure() {
--enable-agetty \
$(use_enable cramfs) \
$(use_enable old-linux elvtune) \
+ --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
--disable-init \
--disable-kill \
--disable-last \
@@ -83,7 +85,6 @@ src_configure() {
--disable-wall \
--enable-write \
--without-pam \
- $(use unicode || echo --with-ncurses) \
$(use_with selinux) \
$(use_with slang) \
$(tc-has-tls || echo --disable-tls)
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index 93fe979adab0..2aeccccbb73d 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.18 2011/03/12 06:33:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.19 2011/04/07 05:18:20 vapier Exp $
EAPI="2"
@@ -24,14 +24,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+cramfs crypt nls old-linux perl selinux slang uclibc unicode"
+IUSE="+cramfs crypt ncurses nls old-linux perl selinux slang uclibc unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
cramfs? ( sys-libs/zlib )
+ ncurses? ( >=sys-libs/ncurses-5.2-r2 )
perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
slang? ( sys-libs/slang )"
@@ -61,6 +61,7 @@ lfs_fallocate_test() {
rm -f "${T}"/fallocate.c
}
+usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
src_configure() {
lfs_fallocate_test
econf \
@@ -69,6 +70,7 @@ src_configure() {
--enable-agetty \
$(use_enable cramfs) \
$(use_enable old-linux elvtune) \
+ --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
--disable-init \
--disable-kill \
--disable-last \
@@ -82,7 +84,6 @@ src_configure() {
--disable-wall \
--enable-write \
--without-pam \
- $(use unicode || echo --with-ncurses) \
$(use_with selinux) \
$(use_with slang) \
$(tc-has-tls || echo --disable-tls)