summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 03:59:27 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 03:59:27 +0000
commit7875309352c8eaca07585927af01247017c9f327 (patch)
tree5eae7a9ceaee4fe7dac608f099a0babe950f9c8a /sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
parentAdd QA_PRESTRIPPED to quiet install warnings. (diff)
downloadgentoo-2-7875309352c8eaca07585927af01247017c9f327.tar.gz
gentoo-2-7875309352c8eaca07585927af01247017c9f327.tar.bz2
gentoo-2-7875309352c8eaca07585927af01247017c9f327.zip
Update to EAPI=5.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild')
-rw-r--r--sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
index 2a54cc199229..0912e6e04c56 100644
--- a/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
+++ b/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild,v 1.5 2015/05/17 03:58:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot-static/yaboot-static-1.3.16-r1.ebuild,v 1.6 2015/05/17 03:59:27 vapier Exp $
+
+# Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe.
+
+EAPI="5"
inherit eutils
DESCRIPTION="Static yaboot ppc boot loader for machines with open firmware"
-### Generated by using quickpkg on a ppc32 machine, compiled with -O2 -pipe
-
HOMEPAGE="http://yaboot.ozlabs.org/"
SRC_URI="mirror://gentoo/yaboot-static-${PV}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* ppc ppc64"
IUSE="ibm"
+
DEPEND="sys-apps/powerpc-utils"
RDEPEND="!sys-boot/yaboot
!ibm? (
@@ -21,6 +25,8 @@ RDEPEND="!sys-boot/yaboot
sys-fs/mac-fdisk
)"
+S=${WORKDIR}
+
QA_PRESTRIPPED="
/usr/lib/yaboot/yaboot
/usr/lib/yaboot/yaboot.chrp
@@ -28,5 +34,5 @@ QA_PRESTRIPPED="
"
src_install() {
- cp -pPR "${WORKDIR}"/* "${D}" || die "cp failed"
+ cp -pPR "${WORKDIR}"/* "${D}" || die
}