summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-06 23:05:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-06 23:05:43 +0000
commit0c0a2f2322fab88fa5cd94deeb1587e7735ee06f (patch)
tree03621ce45e6fb8098eb79501587252cb1e124ecd /sys-devel/autoconf-wrapper
parentFix path for library installation. Bug #331457. Remove old ebuild. Thanks to ... (diff)
downloadgentoo-2-0c0a2f2322fab88fa5cd94deeb1587e7735ee06f.tar.gz
gentoo-2-0c0a2f2322fab88fa5cd94deeb1587e7735ee06f.tar.bz2
gentoo-2-0c0a2f2322fab88fa5cd94deeb1587e7735ee06f.zip
Add a revision supporting autoconf 2.67 that was missing; make it so that the ebuild generates the final file, allowing us to keep a single file between multiple revisions of the wrapper that _only_ introduce new autoconf versions.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/autoconf-wrapper')
-rw-r--r--sys-devel/autoconf-wrapper/ChangeLog11
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild36
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-devel/autoconf-wrapper/ChangeLog b/sys-devel/autoconf-wrapper/ChangeLog
index c2a9cdae13b7..be494c08e9d0 100644
--- a/sys-devel/autoconf-wrapper/ChangeLog
+++ b/sys-devel/autoconf-wrapper/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/autoconf-wrapper
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/ChangeLog,v 1.75 2010/07/05 09:53:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/ChangeLog,v 1.76 2010/08/06 23:05:43 flameeyes Exp $
+
+*autoconf-wrapper-9-r1 (06 Aug 2010)
+
+ 06 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +autoconf-wrapper-9-r1.ebuild:
+ Add a revision supporting autoconf 2.67 that was missing; make it so that
+ the ebuild generates the final file, allowing us to keep a single file
+ between multiple revisions of the wrapper that _only_ introduce new
+ autoconf versions.
05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
autoconf-wrapper-8.ebuild:
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild
new file mode 100644
index 000000000000..07ceefa85f9c
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild,v 1.1 2010/08/06 23:05:43 flameeyes Exp $
+
+inherit multilib
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}
+
+SUPPORTED_AC_VERSIONS="2.67:2.5 2.66:2.5 2.65:2.5 2.64:2.5 2.63:2.5 2.62:2.5 2.61:2.5 2.60:2.5 2.59:2.5 2.13:2.1"
+
+src_compile() {
+ sed -e "/vers=/s|\".*\"|\"${SUPPORTED_AC_VERSIONS}\"|" \
+ "${FILESDIR}"/ac-wrapper-${PV}.sh \
+ > "${T}"/ac-wrapper.sh \
+ || die "ac-wrapper sed failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe "${T}"/ac-wrapper.sh || die
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
+ done
+}