summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-15 06:07:49 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-15 06:07:49 +0000
commit0aaf94d84be0a1e1b93dffe4593c1ce93fb62119 (patch)
tree0045af2cdde6276d0f66e010eee8d40e16e88859 /sys-devel
parenteautomake: fix parsing of version output #509786 by Brian Evans (diff)
downloadgentoo-2-0aaf94d84be0a1e1b93dffe4593c1ce93fb62119.tar.gz
gentoo-2-0aaf94d84be0a1e1b93dffe4593c1ce93fb62119.tar.bz2
gentoo-2-0aaf94d84be0a1e1b93dffe4593c1ce93fb62119.zip
Update to EAPI=4 and unify behavior across versions.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog9
-rw-r--r--sys-devel/automake/automake-1.10.3.ebuild21
-rw-r--r--sys-devel/automake/automake-1.11.6.ebuild43
-rw-r--r--sys-devel/automake/automake-1.12.6.ebuild34
-rw-r--r--sys-devel/automake/automake-1.13.4.ebuild36
-rw-r--r--sys-devel/automake/automake-1.14.1.ebuild23
-rw-r--r--sys-devel/automake/automake-1.4_p6-r1.ebuild20
-rw-r--r--sys-devel/automake/automake-1.5-r1.ebuild23
-rw-r--r--sys-devel/automake/automake-1.6.3-r1.ebuild19
-rw-r--r--sys-devel/automake/automake-1.7.9-r2.ebuild19
-rw-r--r--sys-devel/automake/automake-1.8.5-r4.ebuild19
-rw-r--r--sys-devel/automake/automake-1.9.6-r3.ebuild17
-rw-r--r--sys-devel/automake/automake-9999.ebuild19
13 files changed, 140 insertions, 162 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index f84c4092f7d8..da9d2d3da3e7 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.213 2014/11/15 04:27:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.214 2014/11/15 06:07:49 vapier Exp $
+
+ 15 Nov 2014; Mike Frysinger <vapier@gentoo.org> automake-1.10.3.ebuild,
+ automake-1.11.6.ebuild, automake-1.12.6.ebuild, automake-1.13.4.ebuild,
+ automake-1.14.1.ebuild, automake-1.4_p6-r1.ebuild, automake-1.5-r1.ebuild,
+ automake-1.6.3-r1.ebuild, automake-1.7.9-r2.ebuild, automake-1.8.5-r4.ebuild,
+ automake-1.9.6-r3.ebuild, automake-9999.ebuild:
+ Update to EAPI=4 and unify behavior across versions.
15 Nov 2014; Mike Frysinger <vapier@gentoo.org> -automake-1.13.1.ebuild,
-automake-1.13.2.ebuild, -automake-1.13.3.ebuild, -automake-1.14.ebuild:
diff --git a/sys-devel/automake/automake-1.10.3.ebuild b/sys-devel/automake/automake-1.10.3.ebuild
index 20d336f78fb2..de8f875b77f3 100644
--- a/sys-devel/automake/automake-1.10.3.ebuild
+++ b/sys-devel/automake/automake-1.10.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10.3.ebuild,v 1.12 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10.3.ebuild,v 1.13 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,27 +11,25 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.60
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- chmod a+rx tests/*.test
+src_prepare() {
export WANT_AUTOCONF=2.5
+ chmod a+rx tests/*.test
}
-src_compile() {
- econf --docdir=/usr/share/doc/${PF} || die
- emake || die
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -62,9 +62,8 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
# SLOT the docs and junk
local x
diff --git a/sys-devel/automake/automake-1.11.6.ebuild b/sys-devel/automake/automake-1.11.6.ebuild
index 3b5dd7800aa5..8c5c2b4f6ee1 100644
--- a/sys-devel/automake/automake-1.11.6.ebuild
+++ b/sys-devel/automake/automake-1.11.6.ebuild
@@ -1,50 +1,39 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11.6.ebuild,v 1.10 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11.6.ebuild,v 1.11 2014/11/15 06:07:49 vapier Exp $
-inherit eutils versionator unpacker
+EAPI="4"
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
-
-S="${WORKDIR}/${MY_P}"
-
-# Use Gentoo versioning for slotting.
-SLOT="${PV:0:4}"
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://www.gnu.org/software/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
- chmod a+rx tests/*.test
+src_prepare() {
export WANT_AUTOCONF=2.5
+ chmod a+rx tests/*.test
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true
}
src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
local x
for x in aclocal automake; do
@@ -83,13 +72,13 @@ slot_info_pages() {
src_install() {
emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
rm \
"${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1
+ "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.12.6.ebuild b/sys-devel/automake/automake-1.12.6.ebuild
index 5433b3ca3d84..7489af149315 100644
--- a/sys-devel/automake/automake-1.12.6.ebuild
+++ b/sys-devel/automake/automake-1.12.6.ebuild
@@ -1,23 +1,14 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.12.6.ebuild,v 1.19 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.12.6.ebuild,v 1.20 2014/11/15 06:07:49 vapier Exp $
-inherit eutils versionator unpacker
+EAPI="4"
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://www.gnu.org/software/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
@@ -27,22 +18,21 @@ IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
+src_prepare() {
export WANT_AUTOCONF=2.5
}
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true
+}
+
src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -76,7 +66,7 @@ slot_info_pages() {
src_install() {
emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
rm "${D}"/usr/share/aclocal/README || die
rmdir "${D}"/usr/share/aclocal || die
diff --git a/sys-devel/automake/automake-1.13.4.ebuild b/sys-devel/automake/automake-1.13.4.ebuild
index 2b6697424f9c..0a5dc965f300 100644
--- a/sys-devel/automake/automake-1.13.4.ebuild
+++ b/sys-devel/automake/automake-1.13.4.ebuild
@@ -1,23 +1,14 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.13.4.ebuild,v 1.14 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.13.4.ebuild,v 1.15 2014/11/15 06:07:49 vapier Exp $
-inherit eutils versionator unpacker
+EAPI="4"
-if [[ ${PV/_beta} == ${PV} ]]; then
- MY_P=${P}
- SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
- MY_P="${PN}-${MY_PV}"
-
- # Alpha/beta releases are not distributed on the usual mirrors.
- SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
-fi
+inherit eutils
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://www.gnu.org/software/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
@@ -27,27 +18,26 @@ IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
+src_prepare() {
export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
}
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true
+}
+
src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
}
src_test() {
- emake check || die
+ emake check
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -81,7 +71,7 @@ slot_info_pages() {
src_install() {
emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
rm "${D}"/usr/share/aclocal/README || die
rmdir "${D}"/usr/share/aclocal || die
diff --git a/sys-devel/automake/automake-1.14.1.ebuild b/sys-devel/automake/automake-1.14.1.ebuild
index 56e0fe2c1888..7dce3abfa4d1 100644
--- a/sys-devel/automake/automake-1.14.1.ebuild
+++ b/sys-devel/automake/automake-1.14.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.14.1.ebuild,v 1.3 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.14.1.ebuild,v 1.4 2014/11/15 06:07:49 vapier Exp $
-inherit eutils versionator unpacker
+EAPI="4"
+
+inherit eutils versionator
if [[ ${PV/_beta} == ${PV} ]]; then
MY_P=${P}
@@ -27,26 +29,27 @@ IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
+src_prepare() {
export WANT_AUTOCONF=2.5
}
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true
+}
+
src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
}
src_test() {
- emake check || die
+ emake check
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -80,7 +83,7 @@ slot_info_pages() {
src_install() {
emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
rm "${D}"/usr/share/aclocal/README || die
rmdir "${D}"/usr/share/aclocal || die
diff --git a/sys-devel/automake/automake-1.4_p6-r1.ebuild b/sys-devel/automake/automake-1.4_p6-r1.ebuild
index 00762e0b0232..0e136a7ca343 100644
--- a/sys-devel/automake/automake-1.4_p6-r1.ebuild
+++ b/sys-devel/automake/automake-1.4_p6-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6-r1.ebuild,v 1.11 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6-r1.ebuild,v 1.12 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -10,28 +12,27 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
-DEPEND="dev-lang/perl
- sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-9
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.4-nls-nuisances.patch #121151
epatch "${FILESDIR}"/${PN}-1.4-libtoolize.patch
epatch "${FILESDIR}"/${PN}-1.4-subdirs-89656.patch
epatch "${FILESDIR}"/${PN}-1.4-ansi2knr-stdlib.patch
epatch "${FILESDIR}"/${PN}-1.4-CVE-2009-4029.patch #295357
sed -i 's:error\.test::' tests/Makefile.in #79529
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -66,8 +67,7 @@ slot_info_pages() {
src_install() {
emake install DESTDIR="${D}" \
pkgdatadir=/usr/share/automake-${SLOT} \
- m4datadir=/usr/share/aclocal-${SLOT} \
- || die
+ m4datadir=/usr/share/aclocal-${SLOT}
slot_info_pages
rm -f "${D}"/usr/bin/{aclocal,automake}
dosym automake-${SLOT} /usr/share/automake
diff --git a/sys-devel/automake/automake-1.5-r1.ebuild b/sys-devel/automake/automake-1.5-r1.ebuild
index 9a7d7ce3ea02..87fa161372b4 100644
--- a/sys-devel/automake/automake-1.5-r1.ebuild
+++ b/sys-devel/automake/automake-1.5-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5-r1.ebuild,v 1.15 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5-r1.ebuild,v 1.16 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,26 +11,25 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
-DEPEND="dev-lang/perl
+RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/automake-1.4-nls-nuisances.patch #121151
epatch "${FILESDIR}"/${P}-target_hook.patch
epatch "${FILESDIR}"/${P}-slot.patch
epatch "${FILESDIR}"/${P}-test-fixes.patch #79505
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${P}-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -61,17 +62,15 @@ slot_info_pages() {
}
src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
+ default
slot_info_pages
- local x=
+ local x
for x in aclocal automake ; do
mv "${D}"/usr/bin/${x}{,-${SLOT}} || die "rename ${x}"
mv "${D}"/usr/share/${x}{,-${SLOT}} || die "move ${x}"
done
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
for x in guess sub ; do
diff --git a/sys-devel/automake/automake-1.6.3-r1.ebuild b/sys-devel/automake/automake-1.6.3-r1.ebuild
index 85176e22a6c9..c657e10f851b 100644
--- a/sys-devel/automake/automake-1.6.3-r1.ebuild
+++ b/sys-devel/automake/automake-1.6.3-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3-r1.ebuild,v 1.11 2014/01/17 04:23:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3-r1.ebuild,v 1.12 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,23 +11,22 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${PN}-1.5-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -58,15 +59,13 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
rm -f "${D}"/usr/bin/{aclocal,automake}
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
- local x=
+ local x
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
diff --git a/sys-devel/automake/automake-1.7.9-r2.ebuild b/sys-devel/automake/automake-1.7.9-r2.ebuild
index 73225320a29d..78a1a453a327 100644
--- a/sys-devel/automake/automake-1.7.9-r2.ebuild
+++ b/sys-devel/automake/automake-1.7.9-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r2.ebuild,v 1.11 2014/01/17 04:23:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r2.ebuild,v 1.12 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,26 +11,25 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${P}-infopage-namechange.patch
epatch "${FILESDIR}"/${P}-test-fixes.patch
epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
epatch "${FILESDIR}"/${P}-libtool-2.patch #257544
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${PN}-1.5-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -61,15 +62,13 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
rm -f "${D}"/usr/bin/{aclocal,automake}
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
- local x=
+ local x
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
diff --git a/sys-devel/automake/automake-1.8.5-r4.ebuild b/sys-devel/automake/automake-1.8.5-r4.ebuild
index 32062a8ff9f8..f28dfbf7fc13 100644
--- a/sys-devel/automake/automake-1.8.5-r4.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r4.ebuild,v 1.12 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r4.ebuild,v 1.13 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,26 +11,25 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
epatch "${FILESDIR}"/${PN}-1.9.6-aclocal7-test-sleep.patch #197366
epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${P}-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -61,15 +62,13 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
rm -f "${D}"/usr/bin/{aclocal,automake}
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
- local x=
+ local x
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
diff --git a/sys-devel/automake/automake-1.9.6-r3.ebuild b/sys-devel/automake/automake-1.9.6-r3.ebuild
index 19481dc10135..b555d73ceeff 100644
--- a/sys-devel/automake/automake-1.9.6-r3.ebuild
+++ b/sys-devel/automake/automake-1.9.6-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r3.ebuild,v 1.12 2014/01/17 04:23:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r3.ebuild,v 1.13 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,21 +11,21 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
>=sys-apps/texinfo-4.7
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.9.6-infopage-namechange.patch
epatch "${FILESDIR}"/${P}-include-dir-prefix.patch #107435
epatch "${FILESDIR}"/${P}-ignore-comments.patch #126388
@@ -31,7 +33,6 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${PN}-1.8.5-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -64,7 +65,7 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
local x
@@ -74,8 +75,6 @@ src_install() {
rm -f "${D}"/usr/bin/${x}
done
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
for x in guess sub ; do
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
index 5ec30b930d42..86ff26318570 100644
--- a/sys-devel/automake/automake-9999.ebuild
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-9999.ebuild,v 1.9 2013/12/24 06:48:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-9999.ebuild,v 1.10 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
-EAPI="2"
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
@@ -13,13 +14,14 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI=""
LICENSE="GPL-3"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
KEYWORDS=""
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.60
+ >=sys-devel/autoconf-2.69
>=sys-apps/texinfo-4.7
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
@@ -29,13 +31,17 @@ src_prepare() {
export WANT_AUTOCONF=2.5
# Don't try wrapping the autotools this thing runs as it tends
# to be a bit esoteric, and the script does `set -e` itself.
- ./bootstrap
+ ./bootstrap.sh
}
src_configure() {
econf --docdir=/usr/share/doc/${PF}
}
+src_test() {
+ emake check
+}
+
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
@@ -66,9 +72,8 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
# SLOT the docs and junk
local x