summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 20:12:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 20:12:20 +0000
commitf2671e524f1c012d8a75b14d0f16a63e4d3e72f9 (patch)
treea3acaac445e5846039a247ad79187325832a01b3 /sys-libs/glibc
parentremoved glitz and on-the-fly-crypt from use.masked (diff)
downloadgentoo-2-f2671e524f1c012d8a75b14d0f16a63e4d3e72f9.tar.gz
gentoo-2-f2671e524f1c012d8a75b14d0f16a63e4d3e72f9.tar.bz2
gentoo-2-f2671e524f1c012d8a75b14d0f16a63e4d3e72f9.zip
fix src_test for cross-compilers
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild24
-rw-r--r--sys-libs/glibc/glibc-2.3.6.ebuild24
6 files changed, 84 insertions, 60 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 554acbbbabb6..8e46a9edf3be 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.48 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.49 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1242,16 +1242,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 83fd946346a0..de878b4575ee 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.23 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.24 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1191,16 +1191,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index b01329dc382a..0b36dcc8dba3 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.13 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.14 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1195,16 +1195,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index 7976a7512ad9..9e67e1dde299 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.11 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.12 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1268,16 +1268,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 90d2e166966c..740018fd239d 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.6 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.7 2006/01/14 20:12:20 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -1276,16 +1276,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}
diff --git a/sys-libs/glibc/glibc-2.3.6.ebuild b/sys-libs/glibc/glibc-2.3.6.ebuild
index 56723ffecd14..24dc4a946234 100644
--- a/sys-libs/glibc/glibc-2.3.6.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.12 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.13 2006/01/14 20:12:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1221,16 +1221,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}