summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-08 19:54:31 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-08 19:54:31 +0000
commit73f92c156fe88f070eab45ec1900d394d696ceb9 (patch)
tree9274ea571b6d751d74c1d0c3f38a876298949460 /sys-process/numactl/numactl-2.0.2.ebuild
parentold (diff)
downloadgentoo-2-73f92c156fe88f070eab45ec1900d394d696ceb9.tar.gz
gentoo-2-73f92c156fe88f070eab45ec1900d394d696ceb9.tar.bz2
gentoo-2-73f92c156fe88f070eab45ec1900d394d696ceb9.zip
Fix linking order #248444 by Diego E. Pettenò.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/numactl/numactl-2.0.2.ebuild')
-rw-r--r--sys-process/numactl/numactl-2.0.2.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/sys-process/numactl/numactl-2.0.2.ebuild b/sys-process/numactl/numactl-2.0.2.ebuild
index 7bc480a04847..e8b5d26c6b44 100644
--- a/sys-process/numactl/numactl-2.0.2.ebuild
+++ b/sys-process/numactl/numactl-2.0.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.1 2008/09/29 23:40:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.2 2009/02/08 19:54:31 vapier Exp $
-inherit base eutils toolchain-funcs
+inherit eutils toolchain-funcs
-DESCRIPTION="Utilities and libraries for NUMA systems."
+DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
@@ -15,10 +15,23 @@ IUSE="perl"
RDEPEND="perl? ( dev-lang/perl )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
}
+src_test() {
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+}
+
src_install() {
emake install prefix="${D}/usr" || die
# delete man pages provided by the man-pages package #238805
@@ -29,10 +42,3 @@ src_install() {
rm "${D}"/usr/bin/numastat "${D}"/usr/share/man/man8/numastat.8 || die
fi
}
-
-src_test() {
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- cd test
- ./regress2 || die "regress2 failed!"
-}