summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:15:00 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:15:00 +0000
commit14f2d9af9bbe472e018154161808359ff0b47607 (patch)
tree8ea6b625795a9440b4db92226cda81da52ba6708 /x11-misc/fbdesk/fbdesk-1.2.1.ebuild
parentMark 1.58-r1 stable on ia64 (diff)
downloadgentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.tar.gz
gentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.tar.bz2
gentoo-2-14f2d9af9bbe472e018154161808359ff0b47607.zip
Cleaned up ebuild: fixed LICENSE (its MIT not GPL-2), fixed DEPEND (libpng was specified twice, one conditional on USE=png and one unconditional...); also use make DESTDIR=${D} install over einstall.
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'x11-misc/fbdesk/fbdesk-1.2.1.ebuild')
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
index 1dde8942a393..5059ae24bd94 100644
--- a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.4 2005/05/16 06:07:31 ka0ttic Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.5 2005/10/03 12:15:00 ka0ttic Exp $
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
SRC_URI="http://www.fluxbox.org/download/${P}.tar.gz"
-IUSE="debug png"
-LICENSE="GPL-2"
+LICENSE="MIT"
SLOT="0"
KEYWORDS="x86 ppc ~sparc ia64 ~amd64"
+IUSE="debug png"
-DEPEND="media-libs/libpng
- virtual/x11
+DEPEND="virtual/x11
png? ( media-libs/libpng )"
src_compile() {
econf \
- `use_enable debug` \
- `use_enable png` || die
- emake || die
+ $(use_enable debug) \
+ $(use_enable png) || die "econf failed"
+
+ emake || die "emake failed"
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS COPYING ChangeLog README
}