summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-04-17 10:07:32 +0000
committerJeroen Roovers <jer@gentoo.org>2014-04-17 10:07:32 +0000
commit799ad077b100146cb7359da3ed1d064439757d5e (patch)
tree5fa97159a41851a10c2e56d8b1968d43500e43e4 /x11-misc/xsri
parentbump (diff)
downloadgentoo-2-799ad077b100146cb7359da3ed1d064439757d5e.tar.gz
gentoo-2-799ad077b100146cb7359da3ed1d064439757d5e.tar.bz2
gentoo-2-799ad077b100146cb7359da3ed1d064439757d5e.zip
Explicitly link against libm (bug #507880 by Wolf Armstrong).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xsri')
-rw-r--r--x11-misc/xsri/ChangeLog10
-rw-r--r--x11-misc/xsri/files/xsri-2.1.0-configure.patch26
-rw-r--r--x11-misc/xsri/xsri-2.1.0-r3.ebuild29
3 files changed, 63 insertions, 2 deletions
diff --git a/x11-misc/xsri/ChangeLog b/x11-misc/xsri/ChangeLog
index 24230227fcc8..1085cddc5cae 100644
--- a/x11-misc/xsri/ChangeLog
+++ b/x11-misc/xsri/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xsri
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsri/ChangeLog,v 1.18 2013/12/26 18:56:32 creffett Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsri/ChangeLog,v 1.19 2014/04/17 10:07:32 jer Exp $
+
+*xsri-2.1.0-r3 (17 Apr 2014)
+
+ 17 Apr 2014; Jeroen Roovers <jer@gentoo.org> +xsri-2.1.0-r3.ebuild,
+ +files/xsri-2.1.0-configure.patch:
+ Explicitly link against libm (bug #507880 by Wolf Armstrong).
26 Dec 2013; Chris Reffett <creffett@gentoo.org> -xsri-2.1.0-r1.ebuild:
Remove old wrt bug 496030
diff --git a/x11-misc/xsri/files/xsri-2.1.0-configure.patch b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
new file mode 100644
index 000000000000..c000e7091092
--- /dev/null
+++ b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
@@ -0,0 +1,26 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,5 @@
+ INCLUDES = \
+ $(GTK_CFLAGS) \
+- -DG_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ -DSYSCONFDIR=\"$(sysconfdir)\"
+
+ bin_PROGRAMS = xsri
+--- a/configure.in
++++ b/configure.in
+@@ -26,9 +26,11 @@
+
+ dnl library checks (not using macros/ directory)
+
+-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.13,,
++PKG_CHECK_MODULES(GTK, x11 gtk+-2.0 >= 1.3.13,,
+ AC_MSG_ERROR([*** GTK+-2.0 must be installed to compile xsri]))
+
++AC_CHECK_LIB(m, sqrt)
++
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
diff --git a/x11-misc/xsri/xsri-2.1.0-r3.ebuild b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..3207bed7cd3a
--- /dev/null
+++ b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsri/xsri-2.1.0-r3.ebuild,v 1.1 2014/04/17 10:07:32 jer Exp $
+
+EAPI=5
+inherit autotools eutils rpm
+
+DESCRIPTION="The xsri wallpaper setter from RedHat"
+HOMEPAGE="http://fedoraproject.org"
+SRC_URI="http://download.fedoraproject.org/pub/fedora/linux/releases/15/Everything/source/SRPMS/${P}-17.fc12.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+ doman ../${PN}.1
+}