summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urwid/urwid-0.9.5.ebuild')
-rw-r--r--dev-python/urwid/urwid-0.9.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/urwid/urwid-0.9.5.ebuild b/dev-python/urwid/urwid-0.9.5.ebuild
new file mode 100644
index 000000000000..a38f9785d199
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.5.ebuild,v 1.1 2006/07/17 07:41:45 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}