summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/ChangeLog7
-rw-r--r--dev-python/urwid/files/digest-urwid-0.9.53
-rw-r--r--dev-python/urwid/urwid-0.9.5.ebuild31
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 3c8f6b314a10..2595d310f046 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.13 2006/05/20 21:26:56 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.14 2006/07/17 07:41:45 lucass Exp $
+
+*urwid-0.9.5 (17 Jul 2006)
+
+ 17 Jul 2006; Lukasz Strzygowski <lucass@gentoo.org> +urwid-0.9.5.ebuild:
+ Version bump.
*urwid-0.9.4 (20 May 2006)
diff --git a/dev-python/urwid/files/digest-urwid-0.9.5 b/dev-python/urwid/files/digest-urwid-0.9.5
new file mode 100644
index 000000000000..509d9b8a6a4f
--- /dev/null
+++ b/dev-python/urwid/files/digest-urwid-0.9.5
@@ -0,0 +1,3 @@
+MD5 cb44fe451beef08d9c0901a21ccea2d7 urwid-0.9.5.tar.gz 140623
+RMD160 6cfc0ce7ba0fffe75bc04920ee47d38a3ec31af9 urwid-0.9.5.tar.gz 140623
+SHA256 ec624023b60ef912b22f34bb95ccc51e2dddabb4a3ba6ed51fedd6dfcb8cf6d9 urwid-0.9.5.tar.gz 140623
diff --git a/dev-python/urwid/urwid-0.9.5.ebuild b/dev-python/urwid/urwid-0.9.5.ebuild
new file mode 100644
index 000000000000..a38f9785d199
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.5.ebuild,v 1.1 2006/07/17 07:41:45 lucass Exp $
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}