aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-17 22:36:25 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-17 22:44:37 +0530
commit003d4780cfe5c84107d4ee7d94c3b3fba24c57c1 (patch)
tree184a1a6fcc57b5aaf86863317d0b4e0147562525 /master/Makefile
parentUpdate autotua-slave with ~amd64 KEYWORD (diff)
downloadautotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.tar.gz
autotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.tar.bz2
autotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.zip
Use `make` for autotua-master
* The main reason for this build-system is the absence of librsvg on most servers where autotua-master will be built. Hence, `make dist` will generate .pngs for the tarball * You need to specify the versions only in Makefile/setup.py now * Tarball creation support => we can have an ebuild for autotua-master based on the webapp eclass * New build systems -> 96x96 images are now suffixed with "-large" - Fix master/master/templates/frontpage.html for new images * `make dist` ftw! - Update scripts/do-release.sh for changes - Also fix a few bugs - And remove "scp" support (manual > automatic)
Diffstat (limited to 'master/Makefile')
-rw-r--r--master/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/master/Makefile b/master/Makefile
new file mode 100644
index 0000000..df95c24
--- /dev/null
+++ b/master/Makefile
@@ -0,0 +1,31 @@
+# Copyright: 2008-09 Gentoo Foundation
+# Author(s): Nirbheek Chauhan <nirbheek.chauhan@gmail.com>
+# License: AGPL-3
+#
+
+INSTALL := install
+DISTDIR := .dist/
+BLDDIR := build/
+PN := autotua-master
+PV := 0.0.2
+P := $(PN)-$(PV)
+SUBDIRS := icons
+MAKE := make
+
+all:
+ for dir in $(SUBDIRS) ; do ( cd $$dir ; $(MAKE) all ) ; done
+
+dist:
+ mkdir -p $(DISTDIR)
+ git archive --format=tar --prefix=$(P)/ HEAD | tar x -C $(DISTDIR)
+ cp icons/*.png $(DISTDIR)/$(P)/icons/
+ tar -C $(DISTDIR) -cjf $(P).tar.bz2 $(P)/
+ rm -rf $(DISTDIR)
+
+clean:
+ rm -rf $(BLDDIR) $(DISTDIR)
+ for dir in $(SUBDIRS) ; do ( cd $$dir ; $(MAKE) clean ) ; done
+
+install: all
+ test -n "$(DESTDIR)" || ( echo "Please define DESTDIR" ; exit 1 )
+ ./setup-master.py install --final $(DESTDIR)