aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'master/Makefile')
-rw-r--r--master/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/master/Makefile b/master/Makefile
new file mode 100644
index 0000000..df95c24
--- /dev/null
+++ b/master/Makefile
@@ -0,0 +1,31 @@
+# Copyright: 2008-09 Gentoo Foundation
+# Author(s): Nirbheek Chauhan <nirbheek.chauhan@gmail.com>
+# License: AGPL-3
+#
+
+INSTALL := install
+DISTDIR := .dist/
+BLDDIR := build/
+PN := autotua-master
+PV := 0.0.2
+P := $(PN)-$(PV)
+SUBDIRS := icons
+MAKE := make
+
+all:
+ for dir in $(SUBDIRS) ; do ( cd $$dir ; $(MAKE) all ) ; done
+
+dist:
+ mkdir -p $(DISTDIR)
+ git archive --format=tar --prefix=$(P)/ HEAD | tar x -C $(DISTDIR)
+ cp icons/*.png $(DISTDIR)/$(P)/icons/
+ tar -C $(DISTDIR) -cjf $(P).tar.bz2 $(P)/
+ rm -rf $(DISTDIR)
+
+clean:
+ rm -rf $(BLDDIR) $(DISTDIR)
+ for dir in $(SUBDIRS) ; do ( cd $$dir ; $(MAKE) clean ) ; done
+
+install: all
+ test -n "$(DESTDIR)" || ( echo "Please define DESTDIR" ; exit 1 )
+ ./setup-master.py install --final $(DESTDIR)