aboutsummaryrefslogtreecommitdiff
path: root/pym
diff options
context:
space:
mode:
Diffstat (limited to 'pym')
-rw-r--r--pym/gentoolkit/eclean/cli.py2
-rw-r--r--pym/gentoolkit/eclean/meson.build18
-rwxr-xr-xpym/gentoolkit/ekeyword/ekeyword.py2
-rw-r--r--pym/gentoolkit/ekeyword/meson.build26
-rw-r--r--pym/gentoolkit/ekeyword/tests/meson.build12
-rw-r--r--pym/gentoolkit/enalyze/__init__.py4
-rw-r--r--pym/gentoolkit/enalyze/meson.build17
-rw-r--r--pym/gentoolkit/equery/__init__.py4
-rw-r--r--pym/gentoolkit/equery/meson.build26
-rw-r--r--pym/gentoolkit/eshowkw/__init__.py2
-rw-r--r--pym/gentoolkit/eshowkw/meson.build16
-rwxr-xr-xpym/gentoolkit/imlate/imlate.py2
-rw-r--r--pym/gentoolkit/imlate/meson.build14
-rw-r--r--pym/gentoolkit/meson.build35
-rw-r--r--pym/gentoolkit/revdep_rebuild/__init__.py2
-rw-r--r--pym/gentoolkit/revdep_rebuild/meson.build21
-rw-r--r--pym/gentoolkit/test/eclean/meson.build20
-rw-r--r--pym/gentoolkit/test/equery/meson.build7
-rw-r--r--pym/gentoolkit/test/meson.build16
-rw-r--r--pym/meson.build1
20 files changed, 238 insertions, 9 deletions
diff --git a/pym/gentoolkit/eclean/cli.py b/pym/gentoolkit/eclean/cli.py
index b180641..e3dd540 100644
--- a/pym/gentoolkit/eclean/cli.py
+++ b/pym/gentoolkit/eclean/cli.py
@@ -9,7 +9,7 @@ __author__ = (
+ "modular re-write by: Brian Dolbec (dol-sen)"
)
__email__ = "degrenier@easyconnect.fr, " + "brian.dolbec@gmail.com"
-__version__ = "git"
+__version__ = "@VERSION@"
__productname__ = "eclean"
__description__ = "A cleaning tool for Gentoo distfiles and binaries."
diff --git a/pym/gentoolkit/eclean/meson.build b/pym/gentoolkit/eclean/meson.build
new file mode 100644
index 0000000..8a28284
--- /dev/null
+++ b/pym/gentoolkit/eclean/meson.build
@@ -0,0 +1,18 @@
+
+cli_py = configure_file(
+ input : 'cli.py',
+ output : 'cli.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ '__init__.py',
+ 'clean.py',
+ cli_py,
+ 'exclude.py',
+ 'output.py',
+ 'search.py',
+ ],
+ subdir : 'gentoolkit/eclean'
+)
diff --git a/pym/gentoolkit/ekeyword/ekeyword.py b/pym/gentoolkit/ekeyword/ekeyword.py
index 01946e9..aa4986e 100755
--- a/pym/gentoolkit/ekeyword/ekeyword.py
+++ b/pym/gentoolkit/ekeyword/ekeyword.py
@@ -50,7 +50,7 @@ import portage
from portage.output import colorize, nocolor
-__version__ = "git"
+__version__ = "@VERSION@"
# Operation object that describes how to perform a change.
# Args:
diff --git a/pym/gentoolkit/ekeyword/meson.build b/pym/gentoolkit/ekeyword/meson.build
new file mode 100644
index 0000000..f4f86f8
--- /dev/null
+++ b/pym/gentoolkit/ekeyword/meson.build
@@ -0,0 +1,26 @@
+
+ekeyword_py = configure_file(
+ input : 'ekeyword.py',
+ output : 'ekeyword.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ '__init__.py',
+ ekeyword_py,
+ 'test_ekeyword.py',
+ ],
+ subdir : 'gentoolkit/ekeyword'
+)
+
+install_data(
+ [
+ 'Makefile',
+ 'README',
+ 'pytest.ini',
+ ],
+ install_dir : py.get_install_dir() / 'gentoolkit' / 'ekeyword'
+)
+
+subdir('tests')
diff --git a/pym/gentoolkit/ekeyword/tests/meson.build b/pym/gentoolkit/ekeyword/tests/meson.build
new file mode 100644
index 0000000..3926731
--- /dev/null
+++ b/pym/gentoolkit/ekeyword/tests/meson.build
@@ -0,0 +1,12 @@
+install_data(
+ [
+ 'process-1.ebuild',
+ 'profiles/arches-desc/profiles/arch.list',
+ 'profiles/arches-desc/profiles/arches.desc',
+ 'profiles/arches-desc/profiles/profiles.desc',
+ 'profiles/both/profiles/arch.list',
+ 'profiles/both/profiles/profiles.desc',
+ ],
+ preserve_path: true,
+ install_dir : py.get_install_dir() / 'gentoolkit' / 'ekeyword' / 'tests'
+)
diff --git a/pym/gentoolkit/enalyze/__init__.py b/pym/gentoolkit/enalyze/__init__.py
index 1f099ac..875de2e 100644
--- a/pym/gentoolkit/enalyze/__init__.py
+++ b/pym/gentoolkit/enalyze/__init__.py
@@ -12,8 +12,8 @@
__docformat__ = "epytext"
-# version is dynamically set by distutils sdist
-__version__ = "git"
+# version is dynamically set by meson dist
+__version__ = "@VERSION@"
__productname__ = "enalyze"
__authors__ = "Brian Dolbec, <brian.dolbec@gmail.com>"
diff --git a/pym/gentoolkit/enalyze/meson.build b/pym/gentoolkit/enalyze/meson.build
new file mode 100644
index 0000000..2747677
--- /dev/null
+++ b/pym/gentoolkit/enalyze/meson.build
@@ -0,0 +1,17 @@
+
+__init__py = configure_file(
+ input : '__init__.py',
+ output : '__init__.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ __init__py,
+ 'analyze.py',
+ 'lib.py',
+ 'output.py',
+ 'rebuild.py',
+ ],
+ subdir : 'gentoolkit/enalyze'
+)
diff --git a/pym/gentoolkit/equery/__init__.py b/pym/gentoolkit/equery/__init__.py
index 15a9b6a..7beb631 100644
--- a/pym/gentoolkit/equery/__init__.py
+++ b/pym/gentoolkit/equery/__init__.py
@@ -6,8 +6,8 @@
__all__ = ("format_options", "format_package_names", "mod_usage")
__docformat__ = "epytext"
-# version is dynamically set by distutils sdist
-__version__ = "git"
+# version is dynamically set by meson dist
+__version__ = "@VERSION@"
# =======
# Imports
diff --git a/pym/gentoolkit/equery/meson.build b/pym/gentoolkit/equery/meson.build
new file mode 100644
index 0000000..e6a02c8
--- /dev/null
+++ b/pym/gentoolkit/equery/meson.build
@@ -0,0 +1,26 @@
+
+__init__py = configure_file(
+ input : '__init__.py',
+ output : '__init__.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ __init__py,
+ 'belongs.py',
+ 'check.py',
+ 'depends.py',
+ 'depgraph.py',
+ 'files.py',
+ 'has.py',
+ 'hasuse.py',
+ 'keywords.py',
+ 'list_.py',
+ 'meta.py',
+ 'size.py',
+ 'uses.py',
+ 'which.py',
+ ],
+ subdir : 'gentoolkit/equery'
+)
diff --git a/pym/gentoolkit/eshowkw/__init__.py b/pym/gentoolkit/eshowkw/__init__.py
index 1aa6982..0d65733 100644
--- a/pym/gentoolkit/eshowkw/__init__.py
+++ b/pym/gentoolkit/eshowkw/__init__.py
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
__package__ = "gentoolkit.eshowkw"
-__version__ = "git"
+__version__ = "@VERSION@"
__author__ = "Tomáš Chvátal <scarabeus@gentoo.org>"
import sys, os, fnmatch
diff --git a/pym/gentoolkit/eshowkw/meson.build b/pym/gentoolkit/eshowkw/meson.build
new file mode 100644
index 0000000..b7a838e
--- /dev/null
+++ b/pym/gentoolkit/eshowkw/meson.build
@@ -0,0 +1,16 @@
+
+__init__py = configure_file(
+ input : '__init__.py',
+ output : '__init__.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ __init__py,
+ 'display_pretty.py',
+ 'keywords_content.py',
+ 'keywords_header.py'
+ ],
+ subdir : 'gentoolkit/eshowkw'
+)
diff --git a/pym/gentoolkit/imlate/imlate.py b/pym/gentoolkit/imlate/imlate.py
index 1db322a..0c7ab04 100755
--- a/pym/gentoolkit/imlate/imlate.py
+++ b/pym/gentoolkit/imlate/imlate.py
@@ -4,7 +4,7 @@
# $Id$
# Author: Christian Ruppert <idl0r@gentoo.org>
-__version__ = "git"
+__version__ = "@VERSION@"
# works just with stable keywords!
MAIN_ARCH = "auto" # can be overridden by -m ARCH
diff --git a/pym/gentoolkit/imlate/meson.build b/pym/gentoolkit/imlate/meson.build
new file mode 100644
index 0000000..5208c23
--- /dev/null
+++ b/pym/gentoolkit/imlate/meson.build
@@ -0,0 +1,14 @@
+
+imlate_py = configure_file(
+ input : 'imlate.py',
+ output : 'imlate.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ '__init__.py',
+ imlate_py,
+ ],
+ subdir : 'gentoolkit/imlate'
+)
diff --git a/pym/gentoolkit/meson.build b/pym/gentoolkit/meson.build
new file mode 100644
index 0000000..7908d94
--- /dev/null
+++ b/pym/gentoolkit/meson.build
@@ -0,0 +1,35 @@
+
+py.install_sources(
+ [
+ '__init__.py',
+ 'atom.py',
+ 'base.py',
+ 'cpv.py',
+ 'dbapi.py',
+ 'dependencies.py',
+ 'eprefix.py',
+ 'errors.py',
+ 'flag.py',
+ 'formatters.py',
+ 'helpers.py',
+ 'keyword.py',
+ 'module_base.py',
+ 'package.py',
+ 'pprinter.py',
+ 'profile.py',
+ 'query.py',
+ 'sets.py',
+ 'textwrap_.py',
+ 'versionmatch.py',
+ ],
+ subdir : 'gentoolkit'
+)
+
+subdir('eclean')
+subdir('ekeyword')
+subdir('enalyze')
+subdir('equery')
+subdir('eshowkw')
+subdir('imlate')
+subdir('revdep_rebuild')
+subdir('test')
diff --git a/pym/gentoolkit/revdep_rebuild/__init__.py b/pym/gentoolkit/revdep_rebuild/__init__.py
index 7fba30b..66a943f 100644
--- a/pym/gentoolkit/revdep_rebuild/__init__.py
+++ b/pym/gentoolkit/revdep_rebuild/__init__.py
@@ -3,4 +3,4 @@
# Copyright 2003-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-__version__ = "git"
+__version__ = "@VERSION@"
diff --git a/pym/gentoolkit/revdep_rebuild/meson.build b/pym/gentoolkit/revdep_rebuild/meson.build
new file mode 100644
index 0000000..b73eff8
--- /dev/null
+++ b/pym/gentoolkit/revdep_rebuild/meson.build
@@ -0,0 +1,21 @@
+
+__init__py = configure_file(
+ input : '__init__.py',
+ output : '__init__.py',
+ configuration : conf_data
+)
+
+py.install_sources(
+ [
+ __init__py,
+ 'analyse.py',
+ 'assign.py',
+ 'cache.py',
+ 'collect.py',
+ 'rebuild.py',
+ 'runner.py',
+ 'settings.py',
+ 'stuff.py',
+ ],
+ subdir : 'gentoolkit/revdep_rebuild'
+)
diff --git a/pym/gentoolkit/test/eclean/meson.build b/pym/gentoolkit/test/eclean/meson.build
new file mode 100644
index 0000000..fa1390b
--- /dev/null
+++ b/pym/gentoolkit/test/eclean/meson.build
@@ -0,0 +1,20 @@
+py.install_sources(
+ [
+ '__init__.py',
+ 'creator.py',
+ 'distsupport.py',
+ 'test_clean.py',
+ 'test_search.py',
+ ],
+ subdir : 'gentoolkit/test/eclean'
+)
+
+install_data(
+ [
+ 'Packages',
+ 'distfiles.exclude',
+ 'testdistfiles.tar.gz',
+ ],
+ preserve_path: true,
+ install_dir : py.get_install_dir() / 'gentoolkit' / 'test' / 'eclean'
+)
diff --git a/pym/gentoolkit/test/equery/meson.build b/pym/gentoolkit/test/equery/meson.build
new file mode 100644
index 0000000..02a0df2
--- /dev/null
+++ b/pym/gentoolkit/test/equery/meson.build
@@ -0,0 +1,7 @@
+py.install_sources(
+ [
+ '__init__.py',
+ 'test_init.py',
+ ],
+ subdir : 'gentoolkit/test/equery'
+)
diff --git a/pym/gentoolkit/test/meson.build b/pym/gentoolkit/test/meson.build
new file mode 100644
index 0000000..2d8c0e7
--- /dev/null
+++ b/pym/gentoolkit/test/meson.build
@@ -0,0 +1,16 @@
+py.install_sources(
+ [
+ '__init__.py',
+ 'test_atom.py',
+ 'test_cpv.py',
+ 'test_helpers.py',
+ 'test_keyword.py',
+ 'test_profile.py',
+ 'test_query.py',
+ 'test_syntax.py',
+ ],
+ subdir : 'gentoolkit/test'
+)
+
+subdir('eclean')
+subdir('equery')
diff --git a/pym/meson.build b/pym/meson.build
new file mode 100644
index 0000000..9b1b354
--- /dev/null
+++ b/pym/meson.build
@@ -0,0 +1 @@
+subdir('gentoolkit')